aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Williamson2017-03-19 10:25:05 -0400
committerMike Williamson2017-03-19 10:25:05 -0400
commitf7fd8f3260681f8fb0aef2f815c8306e86c94d51 (patch)
tree43c9d8a4d4189d481f5786ce1869b713d8a43cc2
parent29dde868f0a63c66227f2b9306f51c4afedb38e1 (diff)
downloadaur-f7fd8f3260681f8fb0aef2f815c8306e86c94d51.tar.gz
Bring our systemd unit file closer to arango's
More work needs to be done to rationalize the differences but this is a start.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--arangodb.install13
-rw-r--r--arangodb3.service (renamed from arangodb.service)1
4 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 849b22f82d97..3a3f0946cd6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -20,10 +20,10 @@ pkgbase = arangodb
conflicts = arangodb-latest
conflicts = arangodb-git
source = https://www.arangodb.com/repositories/Source/ArangoDB-3.1.14.tar.bz2
- source = arangodb.service
+ source = arangodb3.service
source = arangodb-tmpfile.conf
sha256sums = 021b7810de22d2a0d6d9513c7e4d2bd0f62076822325f5028a0b56fc0a3e2bf9
- sha256sums = 40ccbb4034aedaa0d2b1d2922d0d9e53271dfa024f421105a988e1f65f1eef51
+ sha256sums = 7de422694ff36683849bd552bec3d5161a52455680a8ea30eba0988dcf5c1c67
sha256sums = 736581ab917755c859d17b4015f68380384f924279aa61c9c160960018e1e4e4
pkgname = arangodb
diff --git a/PKGBUILD b/PKGBUILD
index f0d966f7c5d4..b9f57cf72632 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,9 +18,9 @@ conflicts=("arangodb-latest" "arangodb-git")
options=()
install=arangodb.install
source=("https://www.arangodb.com/repositories/Source/ArangoDB-$pkgver.tar.bz2"
-"arangodb.service" "arangodb-tmpfile.conf")
+"arangodb3.service" "arangodb-tmpfile.conf")
sha256sums=('021b7810de22d2a0d6d9513c7e4d2bd0f62076822325f5028a0b56fc0a3e2bf9'
- '40ccbb4034aedaa0d2b1d2922d0d9e53271dfa024f421105a988e1f65f1eef51'
+ '7de422694ff36683849bd552bec3d5161a52455680a8ea30eba0988dcf5c1c67'
'736581ab917755c859d17b4015f68380384f924279aa61c9c160960018e1e4e4')
build() {
@@ -58,5 +58,5 @@ package() {
msg2 "Preparing systemd service."
mkdir -p $pkgdir/usr/lib/systemd/system
- cp $srcdir/arangodb.service $pkgdir/usr/lib/systemd/system/
+ cp $srcdir/arangodb3.service $pkgdir/usr/lib/systemd/system/
}
diff --git a/arangodb.install b/arangodb.install
index b0ad64ea9587..4379cdb9d02a 100644
--- a/arangodb.install
+++ b/arangodb.install
@@ -25,8 +25,8 @@ post_install() {
files, then enable and start the service:
sudo systemctl daemon-reload
- sudo systemctl enable arangodb.service
- sudo systemctl start arangodb.service
+ sudo systemctl enable arangodb3.service
+ sudo systemctl start arangodb3.service
ArangoDB 3 ships with authentication enabled. To use it you will need
to start the server with 'authentication = false' in the following
@@ -45,7 +45,7 @@ post_install() {
Set the 'authentication = true' and then restart ArangoDB:
- sudo systemctl restart arangodb.service
+ sudo systemctl restart arangodb3.service
You can now use your username and password to access the
administrative interface at:
@@ -69,9 +69,8 @@ post_upgrade() {
between versions. To upgrade existing data files run /usr/bin/arangod
with the upgrade option:
- sudo systemctl stop arangodb.service
- sudo arangod --database.auto-upgrade
- sudo systemctl start arangodb.service
+ sudo systemctl stop arangodb3.service
+ sudo systemctl start arangodb3.service
Take a look at the Changelog to see what is new in $1:
https://github.com/arangodb/arangodb/blob/devel/CHANGELOG
@@ -79,7 +78,7 @@ EOF
}
pre_remove() {
- systemctl stop arangodb.service &> /dev/null
+ systemctl stop arangodb3.service &> /dev/null
}
post_remove() {
diff --git a/arangodb.service b/arangodb3.service
index fdd45d08aac0..1f780ead6044 100644
--- a/arangodb.service
+++ b/arangodb3.service
@@ -26,6 +26,7 @@ PermissionsStartOnly=true
# ExecStartPre run sequentially
ExecStartPre=/usr/bin/chown -R arangodb:arangodb /var/log/arangodb3
ExecStartPre=/usr/bin/chown -R arangodb:arangodb /var/lib/arangodb3
+ExecStartPre=/usr/bin/arangod --pid-file /run/arangodb3/arangod.pid --server.rest-server false --database.auto-upgrade true
ExecStart=/usr/bin/arangod -c /etc/arangodb3/arangod.conf --pid-file /run/arangodb3/arangod.pid --temp.path /var/tmp/arangod --supervisor