summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2016-06-12 11:18:29 +0200
committerJakob Gahde2016-06-12 11:18:29 +0200
commitdccb0517481ba54892155bea64d6b8ad90025fde (patch)
treedf3301e3f89beaa2219ac773144c083da67d0842
downloadaur-dccb0517481ba54892155bea64d6b8ad90025fde.tar.gz
arc-firefox-theme 47.20160607: Initial package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0cafd7f5d2b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Jun 12 09:17:53 UTC 2016
+pkgbase = arc-firefox-theme
+ pkgdesc = Official Arc Firefox theme
+ pkgver = 47.20160607
+ pkgrel = 1
+ url = https://github.com/horst3180/arc-firefox-theme/
+ arch = any
+ license = custom:MPL2.0
+ depends = firefox
+ depends = gtk-theme-arc
+ source = https://github.com/horst3180/arc-firefox-theme/archive/47.20160607.tar.gz
+ sha256sums = ac679c6ff6bd354912915e58be5bd68c6ffc07dea081d8f1ccb41cbc58fb1e24
+
+pkgname = arc-firefox-theme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58bf86983773
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=arc-firefox-theme
+pkgver=47.20160607
+pkgrel=1
+pkgdesc="Official Arc Firefox theme"
+arch=('any')
+url="https://github.com/horst3180/${pkgname}/"
+license=('custom:MPL2.0')
+depends=('firefox' 'gtk-theme-arc')
+source=("https://github.com/horst3180/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('ac679c6ff6bd354912915e58be5bd68c6ffc07dea081d8f1ccb41cbc58fb1e24')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./autogen.sh \
+ --prefix=/usr
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}