summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2018-03-22 10:21:48 -0500
committerfrealgagu2018-03-22 10:21:48 -0500
commit0c773c710500784be37f8e43e7fb951fead2aaff (patch)
treefc7b3187110f00ba888a3ada55c663961f44b241
parent1bd966277b4da759e432d4f101bb47ccdb854eb9 (diff)
downloadaur-0c773c710500784be37f8e43e7fb951fead2aaff.tar.gz
Using new upstream, split solid package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD56
2 files changed, 43 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f08c9bffb8e..cf6277c2c5e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,22 @@
pkgbase = arc-gtk-theme-git
pkgdesc = A flat theme with transparent elements for GTK 3, GTK 2 and Gnome-Shell
- pkgver = 712.51d88f1
+ pkgver = 20180114.r5.906add8
pkgrel = 1
url = https://github.com/nicohood/arc-theme
arch = any
license = GPL3
- makedepends = git
makedepends = gtk3
makedepends = sassc
optdepends = arc-icon-theme: recommended icon theme
optdepends = gtk-engine-murrine: for gtk2 themes
optdepends = gnome-themes-standard: for gtk2 themes
- provides = arc-gtk-theme
- conflicts = arc-gtk-theme
- source = arc-theme::git+https://github.com/nicohood/arc-theme.git
- sha512sums = SKIP
+ source = git+https://github.com/nicohood/arc-theme
+ sha256sums = SKIP
pkgname = arc-gtk-theme-git
+ replaces = gtk-theme-arc-git
+
+pkgname = arc-solid-gtk-theme-git
+ pkgdesc = A flat theme for GTK 3, GTK 2 and Gnome-Shell (without transparency)
+ replaces = gtk-theme-arc-solid-git
diff --git a/PKGBUILD b/PKGBUILD
index 7e11d2f779c3..801fa4a76d36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,57 @@
-# Maintainer: Noeljnuior <liamgliamgmailcom>
-
+# Maintainer: Fredy GarcĂ­a <frealgagu at gmail dot com>
+# Contributor: Noeljnuior <liamgliamgmailcom>
# Contributor: NicoHood <archlinux {cat} nicohood {dog} de>
# Contributor: zach <zach {at} zach-adams {dot} com>
# Contributor: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de
# Contributor: Philipp Wolfer <ph.wolfer@gmail.com>
+pkgbase=arc-gtk-theme-git
_pkgname=arc-theme
-pkgname=arc-gtk-theme-git
+pkgname=("arc-gtk-theme-git" "arc-solid-gtk-theme-git")
pkgdesc="A flat theme with transparent elements for GTK 3, GTK 2 and Gnome-Shell"
-pkgver=712.51d88f1
+pkgver=20180114.r5.906add8
pkgrel=1
-arch=('any')
+arch=("any")
# Upstream url: https://github.com/horst3180/arc-theme
# Now using soft fork: https://github.com/horst3180/arc-theme/issues/840
-url="https://github.com/nicohood/arc-theme"
-license=('GPL3')
-optdepends=('arc-icon-theme: recommended icon theme'
- 'gtk-engine-murrine: for gtk2 themes'
- 'gnome-themes-standard: for gtk2 themes')
-makedepends=('git' 'gtk3' 'sassc')
-source=(${_pkgname}::"git+https://github.com/nicohood/${_pkgname}.git")
-sha512sums=('SKIP')
-conflicts=('arc-gtk-theme')
-provides=('arc-gtk-theme')
+url="https://github.com/nicohood/${_pkgname}"
+license=("GPL3")
+optdepends=("arc-icon-theme: recommended icon theme"
+ "gtk-engine-murrine: for gtk2 themes"
+ "gnome-themes-standard: for gtk2 themes")
+makedepends=("gtk3" "sassc")
+
+source=("git+https://github.com/nicohood/${_pkgname}")
+sha256sums=("SKIP")
pkgver() {
- cd "${srcdir}/${_pkgname}"
- echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g'
+}
+
+prepare() {
+ cp -a ${_pkgname}{,-solid}
}
build() {
- cd ${_pkgname}
+ cd "${srcdir}/${_pkgname}"
./autogen.sh --prefix=/usr
- cd ../${_pkgname}
- ./autogen.sh --prefix=/usr
+ cd "${srcdir}/${_pkgname}-solid"
+ ./autogen.sh --prefix=/usr --disable-transparency
}
-package() {
+package_arc-gtk-theme-git() {
+ replaces=("gtk-theme-arc-git")
+
cd ${_pkgname}
make DESTDIR="${pkgdir}" install
}
+
+package_arc-solid-gtk-theme-git() {
+ pkgdesc="A flat theme for GTK 3, GTK 2 and Gnome-Shell (without transparency)"
+ replaces=("gtk-theme-arc-solid-git")
+
+ cd ${_pkgname}-solid
+ make DESTDIR="${pkgdir}" install
+}