summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaukyo2015-06-11 11:45:20 +0200
committerNaukyo2015-06-11 11:45:20 +0200
commit23e3aede2ac9560b4d2afb6ed2655ff87023b0ec (patch)
treef818102004289cfbf5a72e25766317b8571c7a44
downloadaur-23e3aede2ac9560b4d2afb6ed2655ff87023b0ec.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f3887523da0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = arc-gtk-theme-git
+ pkgdesc = Arc is a flat theme with transparent elements for GTK 3, GTK 2 and Gnome-Shell. It supports GTK 3 and GTK 2 based desktop environments like Gnome, Unity, Budgie, Pantheon, etc.
+ pkgver = 53.74f43ab
+ pkgrel = 1
+ url = https://github.com/horst3180/Arc-theme
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = automake
+ makedepends = autoconf
+ depends = gnome-themes-standard
+ depends = gtk-engine-murrine
+ provides = arc-theme
+ conflicts = arc-theme
+ replaces = arc-theme
+ options = !strip
+ source = arc-gtk-theme-git::git+https://github.com/horst3180/arc-theme.git
+ sha256sums = SKIP
+
+pkgname = arc-gtk-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d621c4aa7a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Malte Ohmstede <malte.ohmstede@gmail.com>
+
+_pkgname=arc-theme
+pkgname=arc-gtk-theme-git
+pkgver=53.74f43ab
+pkgrel=1
+pkgdesc="Arc is a flat theme with transparent elements for GTK 3, GTK 2 and Gnome-Shell. It supports GTK 3 and GTK 2 based desktop environments like Gnome, Unity, Budgie, Pantheon, etc."
+arch=('any')
+url="https://github.com/horst3180/Arc-theme"
+license=('GPL3')
+depends=('gnome-themes-standard' 'gtk-engine-murrine')
+makedepends=('git' 'automake' 'autoconf')
+conflicts=("${_pkgname}")
+provides=("${_pkgname}")
+replaces=("${_pkgname}")
+options=(!strip)
+source=(${pkgname}::"git+https://github.com/horst3180/${_pkgname}.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd ${srcdir}/${pkgname}
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+
+build(){
+ cd $srcdir/$pkgname
+ ./autogen.sh --prefix=/usr
+
+}
+package() {
+ cd $srcdir/$pkgname
+ make DESTDIR="${pkgdir}" install
+}