summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicoHood2018-03-25 21:17:42 +0200
committerNicoHood2018-03-25 21:17:42 +0200
commitbd92bb81cea2c2ed6f292bd8356d0429644dc518 (patch)
tree570359e7d9c9405b9812a9ed63d8a47eb41e8941
parent0c773c710500784be37f8e43e7fb951fead2aaff (diff)
downloadaur-bd92bb81cea2c2ed6f292bd8356d0429644dc518.tar.gz
Cleaned up PKGBUILD, synced with [community] package.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD48
2 files changed, 31 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf6277c2c5e2..012cb7c5a7bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,26 @@
pkgbase = arc-gtk-theme-git
pkgdesc = A flat theme with transparent elements for GTK 3, GTK 2 and Gnome-Shell
- pkgver = 20180114.r5.906add8
+ pkgver = 20170302.r4.8290cb8
pkgrel = 1
url = https://github.com/nicohood/arc-theme
arch = any
license = GPL3
makedepends = gtk3
makedepends = sassc
+ makedepends = git
optdepends = arc-icon-theme: recommended icon theme
optdepends = gtk-engine-murrine: for gtk2 themes
optdepends = gnome-themes-standard: for gtk2 themes
- source = git+https://github.com/nicohood/arc-theme
- sha256sums = SKIP
+ source = arc-theme::git+https://github.com/horst3180/arc-theme.git
+ validpgpkeys = 97312D5EB9D7AE7D0BD4307351DAE9B7C1AE9161
+ sha512sums = SKIP
pkgname = arc-gtk-theme-git
+ conflicts = arc-gtk-theme-git
replaces = gtk-theme-arc-git
pkgname = arc-solid-gtk-theme-git
pkgdesc = A flat theme for GTK 3, GTK 2 and Gnome-Shell (without transparency)
+ conflicts = arc-solid-gtk-theme-git
replaces = gtk-theme-arc-solid-git
diff --git a/PKGBUILD b/PKGBUILD
index 801fa4a76d36..7fe8e79ce6fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,32 @@
-# Maintainer: Fredy GarcĂ­a <frealgagu at gmail dot com>
-# Contributor: Noeljnuior <liamgliamgmailcom>
-# Contributor: NicoHood <archlinux {cat} nicohood {dog} de>
+# Maintainer: NicoHood <archlinux {cat} nicohood {dog} de>
+# PGP ID: 97312D5EB9D7AE7D0BD4307351DAE9B7C1AE9161
# Contributor: zach <zach {at} zach-adams {dot} com>
# Contributor: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de
# Contributor: Philipp Wolfer <ph.wolfer@gmail.com>
pkgbase=arc-gtk-theme-git
_pkgname=arc-theme
-pkgname=("arc-gtk-theme-git" "arc-solid-gtk-theme-git")
+pkgname=('arc-gtk-theme-git' 'arc-solid-gtk-theme-git')
pkgdesc="A flat theme with transparent elements for GTK 3, GTK 2 and Gnome-Shell"
-pkgver=20180114.r5.906add8
+pkgver=20170302.r4.8290cb8
pkgrel=1
-arch=("any")
+arch=('any')
# Upstream url: https://github.com/horst3180/arc-theme
# Now using soft fork: https://github.com/horst3180/arc-theme/issues/840
-url="https://github.com/nicohood/${_pkgname}"
-license=("GPL3")
-optdepends=("arc-icon-theme: recommended icon theme"
- "gtk-engine-murrine: for gtk2 themes"
- "gnome-themes-standard: for gtk2 themes")
-makedepends=("gtk3" "sassc")
+url="https://github.com/nicohood/arc-theme"
+license=('GPL3')
+optdepends=('arc-icon-theme: recommended icon theme'
+ 'gtk-engine-murrine: for gtk2 themes'
+ 'gnome-themes-standard: for gtk2 themes')
+makedepends=('gtk3' 'sassc' 'git')
-source=("git+https://github.com/nicohood/${_pkgname}")
-sha256sums=("SKIP")
+source=("${_pkgname}::git+https://github.com/horst3180/${_pkgname}.git")
+sha512sums=('SKIP')
+validpgpkeys=('97312D5EB9D7AE7D0BD4307351DAE9B7C1AE9161') # NicoHood
pkgver() {
- cd "${srcdir}/${_pkgname}"
- git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g'
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g'
}
prepare() {
@@ -34,24 +34,24 @@ prepare() {
}
build() {
- cd "${srcdir}/${_pkgname}"
+ cd ${_pkgname}
./autogen.sh --prefix=/usr
- cd "${srcdir}/${_pkgname}-solid"
+ cd ../${_pkgname}-solid
./autogen.sh --prefix=/usr --disable-transparency
}
package_arc-gtk-theme-git() {
- replaces=("gtk-theme-arc-git")
+ replaces=('gtk-theme-arc-git')
+ conflicts=('arc-gtk-theme-git')
- cd ${_pkgname}
- make DESTDIR="${pkgdir}" install
+ make -C "${srcdir}/${_pkgname}" DESTDIR="${pkgdir}" install
}
package_arc-solid-gtk-theme-git() {
pkgdesc="A flat theme for GTK 3, GTK 2 and Gnome-Shell (without transparency)"
- replaces=("gtk-theme-arc-solid-git")
+ replaces=('gtk-theme-arc-solid-git')
+ conflicts=('arc-solid-gtk-theme-git')
- cd ${_pkgname}-solid
- make DESTDIR="${pkgdir}" install
+ make -C "${srcdir}/${_pkgname}-solid" DESTDIR="${pkgdir}" install
}