summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Santini2022-07-06 16:48:09 +0200
committerGiovanni Santini2022-07-06 16:48:09 +0200
commit144bc1117691176ad0268220cb95956dbb05f503 (patch)
treeee2b201d3f7ad63c6134599ff502c7b9755b3f9f
parent8515036b768aa74b56b9a72fbcabf7d1a339de0a (diff)
downloadaur-144bc1117691176ad0268220cb95956dbb05f503.tar.gz
upgpkg: arc-kde 20220706-1
- Version bump.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
2 files changed, 12 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fbfc34499d09..1b22a97f918c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,13 @@
pkgbase = arc-kde
pkgdesc = Arc theme for KDE Plasma 5
- pkgver = 20180614
- pkgrel = 3
+ pkgver = 20220706
+ pkgrel = 1
url = https://github.com/PapirusDevelopmentTeam/arc-kde
arch = any
license = GPL3
options = !strip
- source = arc-kde-20180614.tar.gz::https://github.com/PapirusDevelopmentTeam/arc-kde/archive/20180614.tar.gz
- source = arc-kde-plasma5.13.patch::https://github.com/PapirusDevelopmentTeam/arc-kde/commit/b7b7f6d60ed2b19ba9822418c2d43fbcf27c5245.patch
- source = arc-kde-plasma5.16.patch::https://github.com/PapirusDevelopmentTeam/arc-kde/commit/ebe4ed6bd17b2fdb8c17e3784e913e12c6b325d5.patch
- sha256sums = 44267738b2bee20f62cc3f1c150b4eb0aa7ce79f4f5d302102f11d15ffa6de15
- sha256sums = 80d46e6f2c31c655236f3743517396c21ef4a29d93f8d39dfe975afca3e1c7ed
- sha256sums = b43affc425aadca30be1be22b68ac10bacff26dbc60e370faa903c2c6d3d7f24
+ source = arc-kde-20220706.tar.gz::https://github.com/PapirusDevelopmentTeam/arc-kde/archive/20220706.tar.gz
+ sha256sums = 17034da994a42b7f1139996705fb1377914c714ec25d4f39f2b6936984e9bbd3
pkgname = arc-kde
optdepends = kvantum-theme-arc: Arc theme for Kvantum Qt style (recommended)
@@ -19,4 +15,3 @@ pkgname = arc-kde
pkgname = kvantum-theme-arc
pkgdesc = Arc theme for Kvantum
depends = kvantum-qt5
-
diff --git a/PKGBUILD b/PKGBUILD
index e74408e8302f..f29ebbb1e980 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,43 +2,27 @@
pkgbase=arc-kde
pkgname=('arc-kde' 'kvantum-theme-arc')
-pkgver=20180614
-pkgrel=3
+pkgver=20220706
+pkgrel=1
pkgdesc="Arc theme for KDE Plasma 5"
arch=(any)
url="https://github.com/PapirusDevelopmentTeam/${pkgbase}"
license=(GPL3)
options=(!strip)
-source=(${pkgbase}-${pkgver}.tar.gz::"${url}/archive/${pkgver}.tar.gz"
- arc-kde-plasma5.13.patch::"https://github.com/PapirusDevelopmentTeam/arc-kde/commit/b7b7f6d60ed2b19ba9822418c2d43fbcf27c5245.patch"
- arc-kde-plasma5.16.patch::"https://github.com/PapirusDevelopmentTeam/arc-kde/commit/ebe4ed6bd17b2fdb8c17e3784e913e12c6b325d5.patch")
-sha256sums=('44267738b2bee20f62cc3f1c150b4eb0aa7ce79f4f5d302102f11d15ffa6de15'
- '80d46e6f2c31c655236f3743517396c21ef4a29d93f8d39dfe975afca3e1c7ed'
- 'b43affc425aadca30be1be22b68ac10bacff26dbc60e370faa903c2c6d3d7f24')
-
-prepare() {
- cd ${pkgbase}-${pkgver}
- patch -p1 -i ../arc-kde-plasma5.13.patch
- patch -p1 -i ../arc-kde-plasma5.16.patch
-}
+source=(${pkgbase}-${pkgver}.tar.gz::"${url}/archive/${pkgver}.tar.gz")
+sha256sums=('17034da994a42b7f1139996705fb1377914c714ec25d4f39f2b6936984e9bbd3')
package_arc-kde() {
optdepends=('kvantum-theme-arc: Arc theme for Kvantum Qt style (recommended)')
+
cd ${pkgbase}-${pkgver}
- install -d "${pkgdir}"/usr/share
-
- cp -r plasma "${pkgdir}"/usr/share
- cp -r aurorae "${pkgdir}"/usr/share
- cp -r color-schemes "${pkgdir}"/usr/share
- cp -r konsole "${pkgdir}"/usr/share
- cp -r yakuake "${pkgdir}"/usr/share
+ DESTDIR=$pkgdir IGNORE=Kvantum make install
}
package_kvantum-theme-arc() {
pkgdesc="Arc theme for Kvantum"
depends=('kvantum-qt5')
- cd ${pkgbase}-${pkgver}
- install -d "${pkgdir}"/usr/share
- cp -r Kvantum "${pkgdir}"/usr/share
+ cd ${pkgbase}-${pkgver}
+ DESTDIR=$pkgdir THEMES=Kvantum make install
}