summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2020-05-01 18:20:49 +0000
committerAntonio Rojas2020-05-01 18:20:49 +0000
commit8515036b768aa74b56b9a72fbcabf7d1a339de0a (patch)
treec690371334703173419e5c4d2564dc179af3361f
parent819a7fe900f62613794772898a055ed09425815a (diff)
downloadaur-8515036b768aa74b56b9a72fbcabf7d1a339de0a.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD50
2 files changed, 48 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c3bffcf9a76..fbfc34499d09 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,22 @@
pkgbase = arc-kde
pkgdesc = Arc theme for KDE Plasma 5
- pkgver = 20170218
- pkgrel = 1
+ pkgver = 20180614
+ pkgrel = 3
url = https://github.com/PapirusDevelopmentTeam/arc-kde
arch = any
license = GPL3
options = !strip
- source = arc-kde-20170218.tar.gz::https://github.com/PapirusDevelopmentTeam/arc-kde/archive/20170218.tar.gz
- sha256sums = 5c7dbe80f06b027527ada72b43934d116aed0c2a5717a3103946c7c45a5d74d7
+ source = arc-kde-20180614.tar.gz::https://github.com/PapirusDevelopmentTeam/arc-kde/archive/20180614.tar.gz
+ source = arc-kde-plasma5.13.patch::https://github.com/PapirusDevelopmentTeam/arc-kde/commit/b7b7f6d60ed2b19ba9822418c2d43fbcf27c5245.patch
+ source = arc-kde-plasma5.16.patch::https://github.com/PapirusDevelopmentTeam/arc-kde/commit/ebe4ed6bd17b2fdb8c17e3784e913e12c6b325d5.patch
+ sha256sums = 44267738b2bee20f62cc3f1c150b4eb0aa7ce79f4f5d302102f11d15ffa6de15
+ sha256sums = 80d46e6f2c31c655236f3743517396c21ef4a29d93f8d39dfe975afca3e1c7ed
+ sha256sums = b43affc425aadca30be1be22b68ac10bacff26dbc60e370faa903c2c6d3d7f24
pkgname = arc-kde
+ optdepends = kvantum-theme-arc: Arc theme for Kvantum Qt style (recommended)
+
+pkgname = kvantum-theme-arc
+ pkgdesc = Arc theme for Kvantum
+ depends = kvantum-qt5
diff --git a/PKGBUILD b/PKGBUILD
index 3e8b53715daf..e74408e8302f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,44 @@
-# Maintainer: Bruno Pagani (a.k.a. ArchangeGabriel) <bruno.n.pagani@gmail.com>
+# Maintainer: Bruno Pagani <archange@archlinux.org>
-pkgname=arc-kde
-pkgver=20170218
-pkgrel=1
+pkgbase=arc-kde
+pkgname=('arc-kde' 'kvantum-theme-arc')
+pkgver=20180614
+pkgrel=3
pkgdesc="Arc theme for KDE Plasma 5"
-arch=('any')
-url="https://github.com/PapirusDevelopmentTeam/${pkgname}"
-license=('GPL3')
-options=('!strip')
-source=(${pkgname}-${pkgver}.tar.gz::"${url}/archive/${pkgver}.tar.gz")
-sha256sums=('5c7dbe80f06b027527ada72b43934d116aed0c2a5717a3103946c7c45a5d74d7')
+arch=(any)
+url="https://github.com/PapirusDevelopmentTeam/${pkgbase}"
+license=(GPL3)
+options=(!strip)
+source=(${pkgbase}-${pkgver}.tar.gz::"${url}/archive/${pkgver}.tar.gz"
+ arc-kde-plasma5.13.patch::"https://github.com/PapirusDevelopmentTeam/arc-kde/commit/b7b7f6d60ed2b19ba9822418c2d43fbcf27c5245.patch"
+ arc-kde-plasma5.16.patch::"https://github.com/PapirusDevelopmentTeam/arc-kde/commit/ebe4ed6bd17b2fdb8c17e3784e913e12c6b325d5.patch")
+sha256sums=('44267738b2bee20f62cc3f1c150b4eb0aa7ce79f4f5d302102f11d15ffa6de15'
+ '80d46e6f2c31c655236f3743517396c21ef4a29d93f8d39dfe975afca3e1c7ed'
+ 'b43affc425aadca30be1be22b68ac10bacff26dbc60e370faa903c2c6d3d7f24')
-package() {
- cd ${pkgname}-${pkgver}
- mkdir -p ${pkgdir}/usr/share
+prepare() {
+ cd ${pkgbase}-${pkgver}
+ patch -p1 -i ../arc-kde-plasma5.13.patch
+ patch -p1 -i ../arc-kde-plasma5.16.patch
+}
+
+package_arc-kde() {
+ optdepends=('kvantum-theme-arc: Arc theme for Kvantum Qt style (recommended)')
+ cd ${pkgbase}-${pkgver}
+ install -d "${pkgdir}"/usr/share
cp -r plasma "${pkgdir}"/usr/share
cp -r aurorae "${pkgdir}"/usr/share
cp -r color-schemes "${pkgdir}"/usr/share
cp -r konsole "${pkgdir}"/usr/share
- # Not sure whether this is the right place to provide this script…
- rm "${pkgdir}"/usr/share/plasma/desktoptheme/Arc-Dark/fix-menubar.sh
+ cp -r yakuake "${pkgdir}"/usr/share
+}
+
+package_kvantum-theme-arc() {
+ pkgdesc="Arc theme for Kvantum"
+ depends=('kvantum-qt5')
+ cd ${pkgbase}-${pkgver}
+ install -d "${pkgdir}"/usr/share
+
+ cp -r Kvantum "${pkgdir}"/usr/share
}