summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2017-09-12 17:38:14 +0200
committerAlexandre Bouvier2017-09-12 17:38:14 +0200
commit09b361588c7c250d881de0e72d07fedc4b4ba587 (patch)
treec6f0352f1e447561b7cd61e53765562f97c6bae6
parent526f9ec19fdaded58404a1eb59534b8eba395c57 (diff)
downloadaur-09b361588c7c250d881de0e72d07fedc4b4ba587.tar.gz
split wallpapers into his own package
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 18 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68a264e4ec42..d91218ecf36d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,6 +16,7 @@ pkgname = arc-kde-git
depends = plasma-workspace
optdepends = papirus-icon-theme: for a more consistent and beautiful experience (recommended)
optdepends = arc-gtk-theme: for a consistent look in GTK applications
+ optdepends = arc-kde-wallpapers: Arc KDE wallpapers
optdepends = kvantum-theme-arc: Arc theme for Kvantum (recommended)
optdepends = konsole-colorscheme-arc: Arc theme for Konsole
optdepends = yakuake-skin-arc: Arc theme for Yakuake
@@ -24,6 +25,12 @@ pkgname = arc-kde-git
provides = arc-kde
conflicts = arc-kde
+pkgname = arc-kde-wallpapers-git
+ pkgdesc = Arc KDE wallpapers
+ provides = arc-kde-wallpapers
+ conflicts =
+ conflicts = arc-kde-git<2:
+
pkgname = kvantum-theme-arc-git
pkgdesc = Arc theme for Kvantum
depends = kvantum-qt5
diff --git a/PKGBUILD b/PKGBUILD
index 5b45e6362f2b..95ddff53b880 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Maintainer: Alexandre Bouvier <contact@amb.tf>
# Maintainer: Marcus Behrendt <marcus dot behrendt dot eightysix(in numbers) at bigbrothergoogle dot com
_pkgbase=arc-kde
-_pkgname=("${_pkgbase}"
+_pkgname=("${_pkgbase}"{,'-wallpapers'}
'kvantum-theme-arc'
'konsole-colorscheme-arc'
'yakuake-skin-arc'
@@ -44,6 +44,7 @@ package_arc-kde-git() {
depends=('plasma-workspace')
optdepends=('papirus-icon-theme: for a more consistent and beautiful experience (recommended)'
'arc-gtk-theme: for a consistent look in GTK applications'
+ 'arc-kde-wallpapers: Arc KDE wallpapers'
'kvantum-theme-arc: Arc theme for Kvantum (recommended)'
'konsole-colorscheme-arc: Arc theme for Konsole'
'yakuake-skin-arc: Arc theme for Yakuake'
@@ -53,7 +54,15 @@ package_arc-kde-git() {
conflicts=("${_pkgbase}")
install=${pkgbase}.install
- _install plasma aurorae color-schemes wallpapers
+ _install plasma aurorae color-schemes
+}
+
+package_arc-kde-wallpapers-git() {
+ pkgdesc="Arc KDE wallpapers"
+ provides=('arc-kde-wallpapers')
+ conflicts=("${provides[0]}" "${pkgbase}<2:")
+
+ _install wallpapers
}
package_kvantum-theme-arc-git() {