summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2020-05-02 17:40:59 +0200
committerAlexandre Bouvier2020-05-02 17:40:59 +0200
commit44548e2cb7091f325af867ae862e8a80b1136e5d (patch)
tree88d370a69d3febb8cc604809f6447ab75ca2b249
parent22295429d19e90a59048974ef694b9928783d7b8 (diff)
downloadaur-44548e2cb7091f325af867ae862e8a80b1136e5d.tar.gz
unsplit everything
-rw-r--r--.SRCINFO58
-rw-r--r--PKGBUILD104
-rw-r--r--arc-kde-git.install11
3 files changed, 35 insertions, 138 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b01d3aca34f6..4f3a2c629ab0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,58 +1,26 @@
pkgbase = arc-kde-git
- pkgver = 20180614.r9.g544ece1
+ pkgdesc = A port of the popular GTK theme Arc for Plasma 5 desktop with a few additions and extras
+ pkgver = 20180614.r11.g04873ca
pkgrel = 1
epoch = 2
url = https://github.com/PapirusDevelopmentTeam/arc-kde
arch = any
license = GPL3
makedepends = git
- options = !strip
- source = arc-kde-git::git+https://github.com/PapirusDevelopmentTeam/arc-kde.git
- sha256sums = SKIP
-
-pkgname = arc-kde-git
- pkgdesc = Arc theme for KDE Plasma 5
- install = arc-kde-git.install
- depends = plasma-workspace
- optdepends = papirus-icon-theme: for a more consistent and beautiful experience (recommended)
optdepends = arc-gtk-theme: for a consistent look in GTK applications
- optdepends = arc-kde-wallpapers: Arc KDE wallpapers
- optdepends = kvantum-theme-arc: Arc theme for Kvantum (recommended)
- optdepends = konsole-colorscheme-arc: Arc theme for Konsole
- optdepends = yakuake-skin-arc: Arc theme for Yakuake
- optdepends = konversation-theme-arc: Arc theme for Konversation
- optdepends = arc-firefox-theme: Arc theme for Firefox
+ optdepends = konsole: for konsole theme
+ optdepends = konversation: for konversation theme
+ optdepends = kvantum-qt5: for kvantum theme (recommended)
+ optdepends = papirus-icon-theme: for a more consistent and beautiful experience (recommended)
+ optdepends = plasma-desktop: for plasma desktop theme
+ optdepends = yakuake: for yakuake theme
provides = arc-kde
- conflicts = arc-kde
-
-pkgname = arc-kde-wallpapers-git
- pkgdesc = Arc KDE wallpapers
- provides = arc-kde-wallpapers
- conflicts = arc-kde-wallpapers
-
-pkgname = kvantum-theme-arc-git
- pkgdesc = Arc theme for Kvantum
- depends = kvantum-qt5
provides = kvantum-theme-arc
+ conflicts = arc-kde
conflicts = kvantum-theme-arc
+ options = !strip
+ source = arc-kde::git+https://github.com/PapirusDevelopmentTeam/arc-kde.git
+ md5sums = SKIP
-pkgname = konsole-colorscheme-arc-git
- pkgdesc = Arc theme for Konsole
- depends = konsole
- provides = konsole-colorscheme-arc
- conflicts = konsole-colorscheme-arc
- conflicts = arc-kde<2:20180614.r9.g544ece1
-
-pkgname = yakuake-skin-arc-git
- pkgdesc = Arc theme for Yakuake
- depends = yakuake
- provides = yakuake-skin-arc
- conflicts = yakuake-skin-arc
- conflicts = arc-kde<2:20180614.r9.g544ece1
-
-pkgname = konversation-theme-arc-git
- pkgdesc = Arc theme for Konversation
- depends = konversation
- provides = konversation-theme-arc
- conflicts = konversation-theme-arc
+pkgname = arc-kde-git
diff --git a/PKGBUILD b/PKGBUILD
index fad39f13edfe..c55fe1122fa8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,101 +1,41 @@
-#!/bin/bash
-# shellcheck disable=SC2034,SC2164
# Maintainer: Alexandre Bouvier <contact@amb.tf>
# Maintainer: Marcus Behrendt <marcus dot behrendt dot eightysix(in numbers) at bigbrothergoogle dot com
-_pkgbase=arc-kde
-_pkgname=("${_pkgbase}"{,'-wallpapers'}
- 'kvantum-theme-arc'
- 'konsole-colorscheme-arc'
- 'yakuake-skin-arc'
- 'konversation-theme-arc')
-pkgname=("${_pkgname[@]/%/-git}")
-pkgbase=${_pkgbase}-git
-pkgver=20180614.r9.g544ece1
+# shellcheck shell=bash disable=SC2034,SC2164
+_pkgname=arc-kde
+pkgname=${_pkgname}-git
+pkgver=20180614.r11.g04873ca
pkgrel=1
epoch=2
+pkgdesc="A port of the popular GTK theme Arc for Plasma 5 desktop with a few additions and extras"
arch=('any')
-url="https://github.com/PapirusDevelopmentTeam/${_pkgbase}"
+url="https://github.com/PapirusDevelopmentTeam/${_pkgname}"
license=('GPL3')
makedepends=('git')
+optdepends=('arc-gtk-theme: for a consistent look in GTK applications'
+ 'konsole: for konsole theme'
+ 'konversation: for konversation theme'
+ 'kvantum-qt5: for kvantum theme (recommended)'
+ 'papirus-icon-theme: for a more consistent and beautiful experience (recommended)'
+ 'plasma-desktop: for plasma desktop theme'
+ 'yakuake: for yakuake theme')
+provides=("${_pkgname}" 'kvantum-theme-arc')
+conflicts=("${_pkgname}" 'kvantum-theme-arc')
options=('!strip')
-source=("${pkgbase}::git+${url}.git")
-sha256sums=('SKIP')
+source=("${_pkgname}::git+${url}.git")
+md5sums=('SKIP')
pkgver() {
- cd "${pkgbase}"
+ cd ${_pkgname}
git describe --long --tags | sed 's/-/.r/;s/-/./'
}
prepare() {
- cd "${pkgbase}"
+ cd ${_pkgname}
rm -r konversation/themes/papirus{,-dark}/src
}
-_install() {
- cd "${pkgbase}"
+package() {
+ cd ${_pkgname}
# shellcheck disable=SC2154
- install -d "${pkgdir}"/usr/share
- cp -r "$@" "${pkgdir}"/usr/share
-}
-
-package_arc-kde-git() {
- pkgdesc="Arc theme for KDE Plasma 5"
- depends=('plasma-workspace')
- optdepends=('papirus-icon-theme: for a more consistent and beautiful experience (recommended)'
- 'arc-gtk-theme: for a consistent look in GTK applications'
- 'arc-kde-wallpapers: Arc KDE wallpapers'
- 'kvantum-theme-arc: Arc theme for Kvantum (recommended)'
- 'konsole-colorscheme-arc: Arc theme for Konsole'
- 'yakuake-skin-arc: Arc theme for Yakuake'
- 'konversation-theme-arc: Arc theme for Konversation'
- 'arc-firefox-theme: Arc theme for Firefox')
- provides=("${_pkgbase}")
- conflicts=("${_pkgbase}")
- install=${pkgbase}.install
-
- _install plasma aurorae color-schemes
-}
-
-package_arc-kde-wallpapers-git() {
- pkgdesc="Arc KDE wallpapers"
- provides=('arc-kde-wallpapers')
- conflicts=('arc-kde-wallpapers')
-
- _install wallpapers
-}
-
-package_kvantum-theme-arc-git() {
- pkgdesc="Arc theme for Kvantum"
- depends=('kvantum-qt5')
- provides=('kvantum-theme-arc')
- conflicts=('kvantum-theme-arc')
-
- _install Kvantum
-}
-
-package_konsole-colorscheme-arc-git() {
- pkgdesc="Arc theme for Konsole"
- depends=('konsole')
- provides=('konsole-colorscheme-arc')
- conflicts=('konsole-colorscheme-arc' "${_pkgbase}<${epoch}:${pkgver}")
-
- _install konsole
-}
-
-package_yakuake-skin-arc-git() {
- pkgdesc="Arc theme for Yakuake"
- depends=('yakuake')
- provides=('yakuake-skin-arc')
- conflicts=('yakuake-skin-arc' "${_pkgbase}<${epoch}:${pkgver}")
-
- _install yakuake
-}
-
-package_konversation-theme-arc-git() {
- pkgdesc="Arc theme for Konversation"
- depends=('konversation')
- provides=('konversation-theme-arc')
- conflicts=('konversation-theme-arc')
-
- _install konversation
+ make DESTDIR="${pkgdir}" install
}
diff --git a/arc-kde-git.install b/arc-kde-git.install
deleted file mode 100644
index 546745bdc462..000000000000
--- a/arc-kde-git.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- /usr/bin/echo "execute 'rm -rf ~/.cache/plasma-svgelements-Arc-* ~/.cache/plasma_theme_Arc-*.kcache' to delete cache"
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}