summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2021-07-14 19:27:22 +0200
committerAlexandre Bouvier2021-07-14 19:27:22 +0200
commitd1f07df147067cabf74105934c133541c9428efd (patch)
treea846461cd95200776426a258393a3d1aff663af3
parent44548e2cb7091f325af867ae862e8a80b1136e5d (diff)
downloadaur-d1f07df147067cabf74105934c133541c9428efd.tar.gz
cosmetic
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD39
2 files changed, 19 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f3a2c629ab0..8fee15162933 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -23,4 +23,3 @@ pkgbase = arc-kde-git
md5sums = SKIP
pkgname = arc-kde-git
-
diff --git a/PKGBUILD b/PKGBUILD
index c55fe1122fa8..ca577e2eadf0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,40 @@
# Maintainer: Alexandre Bouvier <contact@amb.tf>
-# Maintainer: Marcus Behrendt <marcus dot behrendt dot eightysix(in numbers) at bigbrothergoogle dot com
-# shellcheck shell=bash disable=SC2034,SC2164
+# Contributor: Marcus Behrendt <marcus dot behrendt dot eightysix(in numbers) at bigbrothergoogle dot com
_pkgname=arc-kde
-pkgname=${_pkgname}-git
+pkgname=$_pkgname-git
pkgver=20180614.r11.g04873ca
pkgrel=1
epoch=2
pkgdesc="A port of the popular GTK theme Arc for Plasma 5 desktop with a few additions and extras"
arch=('any')
-url="https://github.com/PapirusDevelopmentTeam/${_pkgname}"
+url="https://github.com/PapirusDevelopmentTeam/arc-kde"
license=('GPL3')
makedepends=('git')
-optdepends=('arc-gtk-theme: for a consistent look in GTK applications'
- 'konsole: for konsole theme'
- 'konversation: for konversation theme'
- 'kvantum-qt5: for kvantum theme (recommended)'
- 'papirus-icon-theme: for a more consistent and beautiful experience (recommended)'
- 'plasma-desktop: for plasma desktop theme'
- 'yakuake: for yakuake theme')
-provides=("${_pkgname}" 'kvantum-theme-arc')
-conflicts=("${_pkgname}" 'kvantum-theme-arc')
+optdepends=(
+ 'arc-gtk-theme: for a consistent look in GTK applications'
+ 'konsole: for konsole theme'
+ 'konversation: for konversation theme'
+ 'kvantum-qt5: for kvantum theme (recommended)'
+ 'papirus-icon-theme: for a more consistent and beautiful experience (recommended)'
+ 'plasma-desktop: for plasma desktop theme'
+ 'yakuake: for yakuake theme'
+)
+provides=("$_pkgname" 'kvantum-theme-arc')
+conflicts=("$_pkgname" 'kvantum-theme-arc')
options=('!strip')
-source=("${_pkgname}::git+${url}.git")
+source=("$_pkgname::git+$url.git")
md5sums=('SKIP')
pkgver() {
- cd ${_pkgname}
- git describe --long --tags | sed 's/-/.r/;s/-/./'
+ cd $_pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd ${_pkgname}
- rm -r konversation/themes/papirus{,-dark}/src
+ rm -rf $_pkgname/konversation/themes/papirus{,-dark}/src
}
package() {
- cd ${_pkgname}
# shellcheck disable=SC2154
- make DESTDIR="${pkgdir}" install
+ make -C $_pkgname DESTDIR="$pkgdir" install
}