summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2017-09-12 00:10:07 +0200
committerAlexandre Bouvier2017-09-12 00:10:07 +0200
commite46851e21af865ef38458eeee2bca92d0895850a (patch)
treec31edff14053c0df9229f08c1dd173c03b252798
parent87c37cfbbc9277c6898e7056685479b1a6f10274 (diff)
downloadaur-e46851e21af865ef38458eeee2bca92d0895850a.tar.gz
transform into a split package
-rw-r--r--.SRCINFO65
-rw-r--r--PKGBUILD124
2 files changed, 131 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0fe98c112e0..f4139c5853b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,56 @@
-# Generated by mksrcinfo v8
-# Sun Sep 10 09:38:33 UTC 2017
pkgbase = arc-kde-git
- pkgdesc = A port of the popular GTK theme Arc for Plasma 5 desktop with a few additions and extras (git version)
- pkgver = r112.0d4ff0e
- pkgrel = 4
- epoch = 1
+ pkgver = 20170908.r15.gb33bc48
+ pkgrel = 1
+ epoch = 2
url = https://github.com/PapirusDevelopmentTeam/arc-kde
- install = arc-kde-git.install
arch = any
- license = GPLv3
+ license = GPL3
makedepends = git
- optdepends = plasma-desktop: For Plasma desktop theme
- optdepends = arc-gtk-theme: A flat theme with transparent elements for GTK 3, GTK 2 and Gnome-Shell
- optdepends = arc-firefox-theme: Arc Firefox theme
- optdepends = kwin: For Aurorae decorations
- optdepends = kvantum-qt5: For Kvantum Theme
- optdepends = konsole: For Konsole color schemes
- optdepends = konversation: For konversation theme
- optdepends = yakuake: For Yakuake theme
- optdepends = eclipse-common
- provides = arc-kde
- conflicts = arc-kde
+ conflicts = arc-kde-git<2:
options = !strip
source = arc-kde-git::git+https://github.com/PapirusDevelopmentTeam/arc-kde.git
sha256sums = SKIP
pkgname = arc-kde-git
+ pkgdesc = Arc theme for KDE Plasma 5
+ install = arc-kde-git.install
+ depends = plasma-workspace
+ optdepends = papirus-icon-theme: for a more consistent and beautiful experience (recommended)
+ optdepends = arc-gtk-theme: for a consistent look in GTK applications
+ optdepends = kvantum-theme-arc: Arc theme for Kvantum (recommended)
+ optdepends = konsole-colorscheme-arc: Arc theme for Konsole
+ optdepends = yakuake-skin-arc: Arc theme for Yakuake
+ optdepends = konversation-theme-arc: Arc theme for Konversation
+ optdepends = arc-firefox-theme: Arc theme for Firefox
+ provides = arc-kde
+ conflicts = arc-kde
+
+pkgname = kvantum-theme-arc-git
+ pkgdesc = Arc theme for Kvantum
+ depends = kvantum-qt5
+ provides = kvantum-theme-arc
+ conflicts = arc-kde-git<2:
+ conflicts =
+
+pkgname = konsole-colorscheme-arc-git
+ pkgdesc = Arc theme for Konsole
+ depends = konsole
+ provides = konsole-colorscheme-arc
+ conflicts = arc-kde-git<2:
+ conflicts =
+ conflicts = arc-kde<2:
+
+pkgname = yakuake-skin-arc-git
+ pkgdesc = Arc theme for Yakuake
+ depends = yakuake
+ provides = yakuake-skin-arc
+ conflicts = arc-kde-git<2:
+ conflicts =
+
+pkgname = konversation-theme-arc-git
+ pkgdesc = Arc theme for Konversation
+ depends = konversation
+ provides = konversation-theme-arc
+ conflicts = arc-kde-git<2:
+ conflicts =
diff --git a/PKGBUILD b/PKGBUILD
index 9df75bc4cba8..684ee785c7ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,94 @@
+#!/bin/bash
+# shellcheck disable=SC2034,SC2164
+# Maintainer: Alexandre Bouvier <contact@amb.tf>
# Maintainer: Marcus Behrendt <marcus dot behrendt dot eightysix(in numbers) at bigbrothergoogle dot com
-
-_with_extra=y
-
-pkgname=arc-kde-git
-epoch=1
-pkgver=r112.0d4ff0e
-pkgrel=4
-pkgdesc='A port of the popular GTK theme Arc for Plasma 5 desktop with a few additions and extras (git version)'
+_pkgbase=arc-kde
+_pkgname=("${_pkgbase}"
+ 'kvantum-theme-arc'
+ 'konsole-colorscheme-arc'
+ 'yakuake-skin-arc'
+ 'konversation-theme-arc')
+pkgname=("${_pkgname[@]/%/-git}")
+pkgbase=${_pkgbase}-git
+pkgver=20170908.r15.gb33bc48
+pkgrel=1
+epoch=2
arch=('any')
-url='https://github.com/PapirusDevelopmentTeam/arc-kde'
-license=('GPLv3')
-options=('!strip')
-conflicts=('arc-kde')
-provides=('arc-kde')
+url="https://github.com/PapirusDevelopmentTeam/${_pkgbase}"
+license=('GPL3')
makedepends=('git')
-optdepends=(
- "plasma-desktop: For Plasma desktop theme"
- "arc-gtk-theme: A flat theme with transparent elements for GTK 3, GTK 2 and Gnome-Shell"
- "arc-firefox-theme: Arc Firefox theme"
- "kwin: For Aurorae decorations"
- "kvantum-qt5: For Kvantum Theme"
- "konsole: For Konsole color schemes"
- "konversation: For konversation theme"
- "yakuake: For Yakuake theme"
-)
-
-if [ -n "${_with_extra}" ]; then
- optdepends+=("eclipse-common")
-
- prepare() {
- sed -i 's|^install:|install:\n\tmkdir -p $(DESTDIR)/usr/share/arc\n\tcp --no-preserve=mode,ownership -r extra $(DESTDIR)/usr/share/arc|' "${srcdir}/${pkgname}/Makefile"
- }
-fi
-
-source=("${pkgname}::git+${url}.git")
+conflicts=("${pkgbase}<2:")
+options=('!strip')
+source=("${pkgbase}::git+${url}.git")
sha256sums=('SKIP')
-install=${pkgname}.install
pkgver() {
- cd "${srcdir}/${pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${pkgbase}"
+ git describe --long --tags | sed 's/-/.r/;s/-/./'
+}
+
+prepare() {
+ cd "${pkgbase}"
+ rm -r konversation/themes/papirus{,-dark}/src
+ mv yakuake/{kns_,}skins
+}
+
+_install() {
+ cd "${pkgbase}"
+ # shellcheck disable=SC2154
+ install -d "${pkgdir}"/usr/share
+ cp -r "$@" "${pkgdir}"/usr/share
+}
+
+package_arc-kde-git() {
+ pkgdesc="Arc theme for KDE Plasma 5"
+ depends=('plasma-workspace')
+ optdepends=('papirus-icon-theme: for a more consistent and beautiful experience (recommended)'
+ 'arc-gtk-theme: for a consistent look in GTK applications'
+ 'kvantum-theme-arc: Arc theme for Kvantum (recommended)'
+ 'konsole-colorscheme-arc: Arc theme for Konsole'
+ 'yakuake-skin-arc: Arc theme for Yakuake'
+ 'konversation-theme-arc: Arc theme for Konversation'
+ 'arc-firefox-theme: Arc theme for Firefox')
+ provides=("${_pkgbase}")
+ conflicts=("${_pkgbase}")
+ install=${pkgbase}.install
+
+ _install plasma aurorae color-schemes wallpapers
}
-package() {
- cd "${pkgname}"
- make DESTDIR="${pkgdir}" install
+package_kvantum-theme-arc-git() {
+ pkgdesc="Arc theme for Kvantum"
+ depends=('kvantum-qt5')
+ provides=('kvantum-theme-arc')
+ conflicts+=("${provides[0]}")
+
+ _install Kvantum
+}
+
+package_konsole-colorscheme-arc-git() {
+ pkgdesc="Arc theme for Konsole"
+ depends=('konsole')
+ provides=('konsole-colorscheme-arc')
+ conflicts+=("${provides[0]}" "${_pkgbase}<2:")
+
+ _install konsole
+}
+
+package_yakuake-skin-arc-git() {
+ pkgdesc="Arc theme for Yakuake"
+ depends=('yakuake')
+ provides=('yakuake-skin-arc')
+ conflicts+=("${provides[0]}")
+
+ _install yakuake
+}
+
+package_konversation-theme-arc-git() {
+ pkgdesc="Arc theme for Konversation"
+ depends=('konversation')
+ provides=('konversation-theme-arc')
+ conflicts+=("${provides[0]}")
+
+ _install konversation
}