summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Milette2017-09-12 12:50:24 -0400
committerCharles Milette2017-09-12 12:50:24 -0400
commit79ed86a87842d97ed9cc7d1f4f4b4fe93ccaf8a2 (patch)
treef1de2d5ae19d3f262f6c2adc15807613aebd0375
parenta578c54a34bb577e4e7982c0d4e9b21b3a07617e (diff)
downloadaur-79ed86a87842d97ed9cc7d1f4f4b4fe93ccaf8a2.tar.gz
Fix conflicts
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--change-solid-theme-path.patch28
-rw-r--r--orange-no-conflict.patch32
4 files changed, 37 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb5f608e8505..e93bdec85686 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,9 +9,9 @@ pkgbase = arc-orange-gtk-theme-git
optdepends = gtk-engine-murrine: for gtk2 themes
optdepends = gnome-themes-standard: for gtk2 themes
source = git+https://github.com/eti0/arc-theme-orange.git
- source = change-solid-theme-path.patch
+ source = orange-no-conflict.patch
sha512sums = SKIP
- sha512sums = 5b1ca739206e386cb4bf1f2f0a9524a08f2590972126cc96ef7c2e56ca59e94136cf7f8dc8184cd1c688a488e5e96384d654e279778f93e8f34860f7281afff9
+ sha512sums = c3b5e0f91e6af117fe3fcb2521d77f50ec7108c43c2a5b1a497d0f00367b5cdc75090864ccb63c04d842db92d6ca6d04717fcc1b9d4ecd436559424b76c2335f
pkgname = arc-orange-gtk-theme-git
pkgdesc = A flat theme with transparent elements for GTK 3, GTK 2 and Gnome-Shell
diff --git a/PKGBUILD b/PKGBUILD
index c46e2832bc48..58a8d08257a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,18 +14,17 @@ optdepends=('arc-icon-theme: recommended icon theme'
'gnome-themes-standard: for gtk2 themes')
makedepends=('gtk3')
source=("git+https://github.com/eti0/${_pkgname}.git"
- 'change-solid-theme-path.patch')
+ 'orange-no-conflict.patch')
sha512sums=('SKIP'
- '5b1ca739206e386cb4bf1f2f0a9524a08f2590972126cc96ef7c2e56ca59e94136cf7f8dc8184cd1c688a488e5e96384d654e279778f93e8f34860f7281afff9')
+ 'c3b5e0f91e6af117fe3fcb2521d77f50ec7108c43c2a5b1a497d0f00367b5cdc75090864ccb63c04d842db92d6ca6d04717fcc1b9d4ecd436559424b76c2335f')
pkgver() {
cd "${srcdir}/${_pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
+ patch -p1 -i ../orange-no-conflict.patch
cp -a ${_pkgname}{,-solid}
- cd ${_pkgname}-solid
- patch -p1 -i ../change-solid-theme-path.patch
}
build() {
diff --git a/change-solid-theme-path.patch b/change-solid-theme-path.patch
deleted file mode 100644
index c1e51e880ed9..000000000000
--- a/change-solid-theme-path.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 7b1d4f3fb9635c21abc4221c008cfa9849fe53ff Mon Sep 17 00:00:00 2001
-From: Patrick Griffis <tingping@tingping.se>
-Date: Wed, 10 May 2017 17:38:54 -0400
-Subject: [PATCH] Append solid suffix to non-transparent variant
-
-This allows distributions to easily pacakge both without conflicts.
-This will also help with Flatpak being able to match the host theme.
----
- common/Makefile.am | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git a/common/Makefile.am b/common/Makefile.am
-index 0421c5de1..58f54d840 100644
---- a/common/Makefile.am
-+++ b/common/Makefile.am
-@@ -1,6 +1,12 @@
-+if !ENABLE_TRANSPARENCY
-+themedir = $(datadir)/themes/Arc-solid
-+themedarkerdir = $(datadir)/themes/Arc-Darker-solid
-+themedarkdir = $(datadir)/themes/Arc-Dark-solid
-+else
- themedir = $(datadir)/themes/Arc
- themedarkerdir = $(datadir)/themes/Arc-Darker
- themedarkdir = $(datadir)/themes/Arc-Dark
-+endif
-
- ithemedir = $(DESTDIR)$(themedir)
- ithemedarkerdir = $(DESTDIR)$(themedarkerdir)
diff --git a/orange-no-conflict.patch b/orange-no-conflict.patch
new file mode 100644
index 000000000000..27c27c1e82bd
--- /dev/null
+++ b/orange-no-conflict.patch
@@ -0,0 +1,32 @@
+From 73ff2d119674efc81d1995154037feb8e2ab639f Mon Sep 17 00:00:00 2001
+From: Charles Milette <charles.milette@gmail.com>
+Date: Tue, 12 Sep 2017 12:39:15 -0400
+Subject: [PATCH] Make Arc and Arc Orange live together
+
+---
+ common/Makefile.am | 12 +++++++++---
+ 1 file changed, 9 insertions(+), 3 deletions(-)
+
+diff --git a/common/Makefile.am b/common/Makefile.am
+index 7966da8..8633b38 100755
+--- a/common/Makefile.am
++++ b/common/Makefile.am
+@@ -1,6 +1,12 @@
+-themedir = $(datadir)/themes/Arc
+-themedarkerdir = $(datadir)/themes/Arc-Darker
+-themedarkdir = $(datadir)/themes/Arc-Dark
++if !ENABLE_TRANSPARENCY
++ themedir = $(datadir)/themes/Arc-Orange-solid
++ themedarkerdir = $(datadir)/themes/Arc-Darker-Orange-solid
++ themedarkdir = $(datadir)/themes/Arc-Dark-Orange-solid
++else
++ themedir = $(datadir)/themes/Arc-Orange
++ themedarkerdir = $(datadir)/themes/Arc-Darker-Orange
++ themedarkdir = $(datadir)/themes/Arc-Dark-Orange
++endif
+
+ ithemedir = $(DESTDIR)$(themedir)
+ ithemedarkerdir = $(DESTDIR)$(themedarkerdir)
+--
+2.14.1
+