summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValHue2018-05-01 12:31:46 +0200
committerValHue2018-05-01 12:31:46 +0200
commita0ed86510708154a34cecd479d587c23a30a1e56 (patch)
tree154d87bb9095b0a25cb32170d01ff9bc08c1218c
downloadaur-a0ed86510708154a34cecd479d587c23a30a1e56.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2d47cc68b269
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = arc-x-icon-theme
+ pkgdesc = Modern free desktop icon theme whose design is based around the use of bold colours and simple geometric shapes to compose icons with pixel perfect rendering.
+ pkgver = 2.1
+ pkgrel = 1
+ url = https://github.com/LinxGem33/Arc-X-Icons
+ arch = any
+ license = GPL3
+ license = CC-BY-SA-4.0
+ depends = gtk-update-icon-cache
+ depends = paper-icon-theme
+ provides = arc-x-icon-theme
+ conflicts = arc-x-icon-theme-git
+ options = !strip
+ source = arc-x-icon-theme-2.1.tar.gz::https://github.com/LinxGem33/Arc-X-Icons/archive/v2.1.tar.gz
+ sha256sums = 0f8f1c381f42b27c13a1489e23d530f47bc8fe57a6a76741247d2d5320f2d8b0
+
+pkgname = arc-x-icon-theme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c3a9fdcf52e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: ValHue <vhuelamo at gmail dot com>
+#
+# Contributor: ValHue <vhuelamo at gmail dot com>
+#
+_pkgname="Arc-X-Icons"
+pkgname="arc-x-icon-theme"
+pkgver=2.1
+pkgrel=1
+pkgdesc="Modern free desktop icon theme whose design is based around the\
+ use of bold colours and simple geometric shapes to compose icons with\
+ pixel perfect rendering."
+url="https://github.com/LinxGem33/Arc-X-Icons"
+arch=('any')
+license=('GPL3' 'CC-BY-SA-4.0')
+depends=('gtk-update-icon-cache' 'paper-icon-theme')
+provides=("${pkgname}")
+conflicts=("${pkgname}-git")
+options=('!strip')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/LinxGem33/${_pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('0f8f1c381f42b27c13a1489e23d530f47bc8fe57a6a76741247d2d5320f2d8b0')
+
+prepare() {
+ cd "${_pkgname}-${pkgver}"
+ sed -i 's|Name=Arc|Name=Arc-X-D|' "src/Arc-OSX-D/index.theme"
+ sed -i 's|Name=Arc|Name=Arc-X-P|' "src/Arc-OSX-P/index.theme"
+ mv "src/Arc-OSX-D" "src/Arc-X-D"
+ mv "src/Arc-OSX-P" "src/Arc-X-P"
+ rm -rf "src/Paper"*
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ install -d ${pkgdir}/usr/share/{icons,licenses/${pkgname}}
+ cp -a src/* "${pkgdir}/usr/share/icons/"
+ install -D -m644 ./{LICENSE,COPYING} "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
+
+# vim:set ts=4 sw=2 ft=sh et syn=sh ft=sh: