summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorabsrdspc2022-03-02 07:14:36 +0300
committerabsrdspc2022-03-02 07:17:11 +0300
commit2486aec5a78fb1eabf7a8c024a170446ba36ce19 (patch)
treee1fdc649155764a5dbfcd09ef3d3c72d61726d77
parentc22c8ff78afc86396c204d05a8b74d653f33062c (diff)
downloadaur-2486aec5a78fb1eabf7a8c024a170446ba36ce19.tar.gz
update + fix include
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
-rw-r--r--limits.patch12
3 files changed, 28 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c14329e3997..40ad65528485 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = arc_unpacker-git
pkgdesc = CLI tool for extracting images and sounds from visual novels.
- pkgver = r2427.9c2781fc
- pkgrel = 1
+ pkgver = r2428.456834ec
+ pkgrel = 2
url = https://github.com/vn-tools/arc_unpacker
arch = x86_64
license = GPL
@@ -18,8 +18,10 @@ pkgbase = arc_unpacker-git
source = arc_unpacker-git::git+https://github.com/vn-tools/arc_unpacker.git
source = catch.hpp::https://raw.githubusercontent.com/catchorg/Catch2/v2.13.4/single_include/catch2/catch.hpp
source = etc.patch
+ source = limits.patch
sha256sums = SKIP
sha256sums = 6e0fa3dd160891a01c1f3b34e8bcd6e0140abe08eca022e390027f27dec2050b
sha256sums = e8c02f338aca81df79f6d5c0e302322abd776b2aeb36eb0a57ee93335c0da216
+ sha256sums = 83c82ea28e61b8acb296c33a1a8336c8ac54163b3fa0fd7edd57cd35d72bd671
pkgname = arc_unpacker-git
diff --git a/PKGBUILD b/PKGBUILD
index 66bb5669c3e2..9ccbbeca3080 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: absrdspc <repom2@riseup.net>
pkgname=arc_unpacker-git
_pkgname=arc_unpacker
-pkgver=r2427.9c2781fc
-pkgrel=1
+pkgver=r2428.456834ec
+pkgrel=2
pkgdesc="CLI tool for extracting images and sounds from visual novels."
arch=(x86_64)
url="https://github.com/vn-tools/arc_unpacker"
@@ -14,10 +14,12 @@ provides=('arc_unpacker-git' 'arc_unpacker')
conflicts=('arc_unpacker')
source=("$pkgname::git+https://github.com/vn-tools/arc_unpacker.git"
'catch.hpp::https://raw.githubusercontent.com/catchorg/Catch2/v2.13.4/single_include/catch2/catch.hpp'
- 'etc.patch')
+ 'etc.patch'
+ 'limits.patch')
sha256sums=('SKIP'
'6e0fa3dd160891a01c1f3b34e8bcd6e0140abe08eca022e390027f27dec2050b'
- 'e8c02f338aca81df79f6d5c0e302322abd776b2aeb36eb0a57ee93335c0da216')
+ 'e8c02f338aca81df79f6d5c0e302322abd776b2aeb36eb0a57ee93335c0da216'
+ '83c82ea28e61b8acb296c33a1a8336c8ac54163b3fa0fd7edd57cd35d72bd671')
pkgver() {
cd "$pkgname"
@@ -26,10 +28,16 @@ pkgver() {
prepare() {
cd "$pkgname"
+
# fix sources path
sed -i "s|\/\.\.\/|\/|g" CMakeLists.txt
+
# fix etc/ path
git apply "$srcdir/etc.patch"
+
+ # fix includes
+ git apply "$srcdir/limits.patch"
+
# fix tests
cp "$srcdir/catch.hpp" tests/test_support/catch.h
}
diff --git a/limits.patch b/limits.patch
new file mode 100644
index 000000000000..e551c63c11f6
--- /dev/null
+++ b/limits.patch
@@ -0,0 +1,12 @@
+diff --git a/src/dec/eagls/pak_archive_decoder.h b/src/dec/eagls/pak_archive_decoder.h
+index 3ffa8793..9b134839 100644
+--- a/src/dec/eagls/pak_archive_decoder.h
++++ b/src/dec/eagls/pak_archive_decoder.h
+@@ -18,6 +18,7 @@
+ #pragma once
+
+ #include "dec/base_archive_decoder.h"
++#include <limits>
+
+ namespace au {
+ namespace dec {