summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorabsrdspc2023-06-05 20:46:23 +0300
committerabsrdspc2023-06-05 20:49:03 +0300
commit8c5c5121b23813c7650db19cb617b409d8fdcc9f (patch)
treefa5bb9c2d739fc0d3893ed53bb30e0ca4f65b95b
parentbda1ad9f69e6802e703b2e6913d71a36d76cfef9 (diff)
downloadaur-8c5c5121b23813c7650db19cb617b409d8fdcc9f.tar.gz
fix includes + bump rel
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--include_cstdint.patch12
-rw-r--r--include_limits.patch (renamed from limits.patch)0
4 files changed, 23 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 241f053bae41..22c499010666 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = arc_unpacker-git
pkgdesc = CLI tool for extracting images and sounds from visual novels.
pkgver = r2428.456834ec
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/vn-tools/arc_unpacker
arch = x86_64
license = GPL
@@ -18,12 +18,14 @@ pkgbase = arc_unpacker-git
source = arc_unpacker-git::git+https://github.com/vn-tools/arc_unpacker.git
source = catch.hpp::https://raw.githubusercontent.com/catchorg/Catch2/v2.13.8/single_include/catch2/catch.hpp
source = etc.patch
- source = limits.patch
+ source = include_limits.patch
+ source = include_cstdint.patch
source = failing_tests.patch
sha256sums = SKIP
sha256sums = f5adf6a4c3237920421d51a11112904084043b015acf2c9058e8f36b92ab2921
sha256sums = e8c02f338aca81df79f6d5c0e302322abd776b2aeb36eb0a57ee93335c0da216
sha256sums = 83c82ea28e61b8acb296c33a1a8336c8ac54163b3fa0fd7edd57cd35d72bd671
+ sha256sums = 91e33edbefc17afd2613d9b571d558f0df244dfb6c77d51c103ed3d72c488ec3
sha256sums = 61244eb2ec5ef7ccfb0a0532d51c256d2e99304098b143522f2bee8da3b8eac0
pkgname = arc_unpacker-git
diff --git a/PKGBUILD b/PKGBUILD
index 7bfafb0a8544..4f73796512c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=arc_unpacker-git
_pkgname=arc_unpacker
pkgver=r2428.456834ec
-pkgrel=2
+pkgrel=3
pkgdesc="CLI tool for extracting images and sounds from visual novels."
arch=(x86_64)
url="https://github.com/vn-tools/arc_unpacker"
@@ -15,12 +15,14 @@ conflicts=('arc_unpacker')
source=("$pkgname::git+https://github.com/vn-tools/arc_unpacker.git"
'catch.hpp::https://raw.githubusercontent.com/catchorg/Catch2/v2.13.8/single_include/catch2/catch.hpp'
'etc.patch'
- 'limits.patch'
+ 'include_limits.patch'
+ 'include_cstdint.patch'
'failing_tests.patch')
sha256sums=('SKIP'
'f5adf6a4c3237920421d51a11112904084043b015acf2c9058e8f36b92ab2921'
'e8c02f338aca81df79f6d5c0e302322abd776b2aeb36eb0a57ee93335c0da216'
'83c82ea28e61b8acb296c33a1a8336c8ac54163b3fa0fd7edd57cd35d72bd671'
+ '91e33edbefc17afd2613d9b571d558f0df244dfb6c77d51c103ed3d72c488ec3'
'61244eb2ec5ef7ccfb0a0532d51c256d2e99304098b143522f2bee8da3b8eac0')
pkgver() {
@@ -38,7 +40,9 @@ prepare() {
git apply "$srcdir/etc.patch"
# fix includes
- git apply "$srcdir/limits.patch"
+ for p in "$srcdir"/include_*.patch; do
+ git apply "$p"
+ done
# fix tests
cp "$srcdir/catch.hpp" tests/test_support/catch.h
diff --git a/include_cstdint.patch b/include_cstdint.patch
new file mode 100644
index 000000000000..5a98d7060073
--- /dev/null
+++ b/include_cstdint.patch
@@ -0,0 +1,12 @@
+diff --git a/src/types.h b/src/types.h
+index 50b0afec..776dcd9d 100644
+--- a/src/types.h
++++ b/src/types.h
+@@ -19,6 +19,7 @@
+
+ #include <string>
+ #include <vector>
++#include <cstdint>
+
+ namespace au {
+
diff --git a/limits.patch b/include_limits.patch
index e551c63c11f6..e551c63c11f6 100644
--- a/limits.patch
+++ b/include_limits.patch