summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorabsrdspc2021-02-13 22:03:04 +0300
committerabsrdspc2021-02-13 22:03:04 +0300
commit92894401801c96810ea53e44aa6584bcd59d3d96 (patch)
tree30544b9b278e82716c2220d972fbd272305b92f8
parenta7cd1663939bbe263f3e27ee751b42239b743480 (diff)
downloadaur-92894401801c96810ea53e44aa6584bcd59d3d96.tar.gz
run tests after build
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c21ae6071f0..8703dc9c27f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -42,6 +42,11 @@ build() {
make
}
+check() {
+ cd "$pkgname"
+ ./run_tests
+}
+
package() {
cd "$srcdir/$pkgname/"
install -D -m 755 ${_pkgname} ${pkgdir}/usr/bin/${_pkgname}