summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorabsrdspc2021-02-13 21:38:16 +0300
committerabsrdspc2021-02-13 21:38:16 +0300
commita7cd1663939bbe263f3e27ee751b42239b743480 (patch)
treec5a8ceb305d698dcecc2cc62ffbc859fc6b58ef4
parent287f3bc52e1007279802f073635406d3349d86d4 (diff)
downloadaur-a7cd1663939bbe263f3e27ee751b42239b743480.tar.gz
fix tests
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 6 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d73e5714cdf7..86e4dd9f76df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,8 +15,10 @@ pkgbase = arc_unpacker-git
provides = arc_unpacker
conflicts = arc_unpacker
source = arc_unpacker-git::git+https://github.com/vn-tools/arc_unpacker.git
+ source = catch.hpp::https://raw.githubusercontent.com/catchorg/Catch2/v2.13.4/single_include/catch2/catch.hpp
source = lcg.patch
sha256sums = SKIP
+ sha256sums = 6e0fa3dd160891a01c1f3b34e8bcd6e0140abe08eca022e390027f27dec2050b
sha256sums = 37f3c1f1969ec9ed537a5cff79e3eb712fb2f317fcf99508eaa8bb250104a003
pkgname = arc_unpacker-git
diff --git a/PKGBUILD b/PKGBUILD
index 82c60ad8e060..4c21ae6071f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,8 +13,10 @@ makedepends=('boost')
provides=('arc_unpacker-git' 'arc_unpacker')
conflicts=('arc_unpacker')
source=("$pkgname::git+https://github.com/vn-tools/arc_unpacker.git"
+ 'catch.hpp::https://raw.githubusercontent.com/catchorg/Catch2/v2.13.4/single_include/catch2/catch.hpp'
'lcg.patch')
sha256sums=('SKIP'
+ '6e0fa3dd160891a01c1f3b34e8bcd6e0140abe08eca022e390027f27dec2050b'
'37f3c1f1969ec9ed537a5cff79e3eb712fb2f317fcf99508eaa8bb250104a003')
pkgver() {
@@ -30,6 +32,8 @@ prepare() {
sed -i "s|program\_path\.parent()|io\:\:path(\"/usr/share/${_pkgname}\")|g" src/io/program_path.cc
# FIX logic_error
git apply "$srcdir/lcg.patch"
+ # FIX tests
+ cp "$srcdir/catch.hpp" tests/test_support/catch.h
}
build() {