summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVas2017-07-22 18:13:14 +0200
committerVas2017-07-22 18:13:14 +0200
commitae7f994c53f4933b7709246afd0287588b1e603c (patch)
tree5237ef7398dafc4600f308d1ce4f2e2517b2e10c
downloadaur-ae7f994c53f4933b7709246afd0287588b1e603c.tar.gz
first commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD42
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dec87b2b37de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Sat Jul 22 16:09:52 UTC 2017
+pkgbase = arc_unpacker-git
+ pkgdesc = CLI tool for extracting images and sounds from visual novels.
+ pkgver = r2414.89eae41c
+ pkgrel = 1
+ url = https://github.com/vn-tools/arc_unpacker
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ depends = boost-libs
+ depends = libpng
+ depends = libjpeg-turbo
+ depends = openssl
+ optdepends = libwebp
+ provides = arc_unpacker-git
+ provides = arc_unpacker
+ conflicts = arc_unpacker
+ source = arc_unpacker-git::git+https://github.com/vn-tools/arc_unpacker.git
+ md5sums = SKIP
+
+pkgname = arc_unpacker-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4cfc12c30771
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Sebba <sebba at cock dot li>
+pkgname=arc_unpacker-git
+_pkgname=arc_unpacker
+pkgver=r2414.89eae41c
+pkgrel=1
+pkgdesc="CLI tool for extracting images and sounds from visual novels."
+arch=(x86_64)
+url="https://github.com/vn-tools/arc_unpacker"
+license=('GPL')
+depends=('boost-libs' 'libpng' 'libjpeg-turbo' 'openssl')
+optdepends=('libwebp')
+makedepends=('boost')
+provides=('arc_unpacker-git' 'arc_unpacker')
+conflicts=('arc_unpacker')
+source=("$pkgname::git+https://github.com/vn-tools/arc_unpacker.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$pkgname"
+ # FIX sources path
+ sed -i "s|\/\.\.\/|\/|g" CMakeLists.txt
+ # FIX etc/ path
+ sed -i "s|program\_path\.parent()|io\:\:path(\"/usr/share/${_pkgname}\")|g" src/io/program_path.cc
+}
+
+build() {
+ cd "$pkgname"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr/bin/ -DCMAKE_BUILD_TYPE=Release .
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname/"
+ install -D -m 755 ${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
+ mkdir -p ${pkgdir}/usr/share/${_pkgname}
+ cp -r etc ${pkgdir}/usr/share/${_pkgname}
+}