summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista2015-06-08 12:11:15 +0200
committerFrancesco Colista2015-06-08 12:11:15 +0200
commit979782bfeaf453fd01b103588d2e1137f5354301 (patch)
treee80c9dd38d5ba8b7f84f147c47b32d631eaab13f
downloadaur-979782bfeaf453fd01b103588d2e1137f5354301.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
-rw-r--r--arcadia.install6
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36984bd20247
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = arcadia
+ pkgdesc = A light IDE for Ruby
+ pkgver = 1.0.0
+ pkgrel = 0
+ url = http://arcadia.rubyforge.org/
+ install = arcadia.install
+ arch = any
+ license = RUBY
+ depends = ruby
+ depends = ruby-coderay>1.0
+ optdepends = ctags: other languages support
+ optdepends = xterm: termina integration
+ optdepends = ruby-debug: debug support
+ source = http://rubygems.org/downloads/arcadia-1.0.0.gem
+ md5sums = e12e52a2def29191bddbc03cc9e76bd9
+
+pkgname = arcadia
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2660b155b28
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+# Contributor: Christoph Zeiler <rabyte*gmail>
+
+pkgname=arcadia
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="A light IDE for Ruby"
+arch=('any')
+url="http://arcadia.rubyforge.org/"
+install=$pkgname.install
+license=('RUBY')
+depends=('ruby' 'ruby-coderay>1.0')
+optdepends=('ctags: other languages support'
+ 'xterm: termina integration'
+ 'ruby-debug: debug support')
+source=(http://rubygems.org/downloads/$pkgname-$pkgver.gem)
+md5sums=('e12e52a2def29191bddbc03cc9e76bd9')
+build() {
+ cd "$srcdir"
+}
+
+package() {
+ cd "$srcdir"
+ local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+ gem install $pkgname-$pkgver.gem --ignore-dependencies -i "$pkgdir$_gemdir" --no-user-install -n "$pkgdir/usr/bin"
+ ln -sf arc "$pkgdir/usr/bin/$pkgname"
+}
diff --git a/arcadia.install b/arcadia.install
new file mode 100644
index 000000000000..bd8fe30d766e
--- /dev/null
+++ b/arcadia.install
@@ -0,0 +1,6 @@
+post_install() {
+ # This is needed because makepkg doesn't look at AUR repositories for dependencies
+ echo -n " * Now you have to install coderay with:\n"
+ echo -n " yaourt -S ruby-coderay\n"
+ echo -n " (ruby-coderay is a dependency of arcadia).\n"
+}