summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordaurnimator2018-10-02 00:14:18 +1000
committerdaurnimator2018-10-02 00:14:18 +1000
commit1cf4a53abf723abbab7b63acf55b6ef8a143a00c (patch)
treef8a2ec6b240b5ed0ef42c6c5dfce7bfe2c9fb4be
parent9fa5fce60015904bef090492e94302d12112e22f (diff)
downloadaur-1cf4a53abf723abbab7b63acf55b6ef8a143a00c.tar.gz
Fix missing documentation + other minor issues
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--arcan.sh12
3 files changed, 10 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5cd49b699ab..55fed790371d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = arcan
pkgdesc = Game Engine meets a Display Server meets a Multimedia Framework
pkgver = 0.5.5
- pkgrel = 1
- url = http://arcan-fe.com
+ pkgrel = 2
+ url = https://arcan-fe.com
arch = x86_64
license = GPL
license = LGPL
@@ -29,7 +29,7 @@ pkgname = arcan-acfgfs
depends = fuse3
pkgname = arcan-aclip
- pkgdesc = Arcan clipboard integration, similarly to how xclip works for Xorg
+ pkgdesc = Arcan clipboard integration, similarly to how "xclip" works for Xorg
depends = arcan
pkgname = arcan-aloadimage
diff --git a/PKGBUILD b/PKGBUILD
index 0ac599e0db2c..674a477ee705 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,10 +13,10 @@ pkgname=('arcan'
'arcan-shmmon'
'arcan-vrbridge')
pkgver=0.5.5
-pkgrel=1
+pkgrel=2
pkgdesc='Game Engine meets a Display Server meets a Multimedia Framework'
arch=('x86_64')
-url='http://arcan-fe.com'
+url='https://arcan-fe.com'
license=('GPL' 'LGPL' 'BSD')
makedepends=('cmake'
'fuse3'
@@ -30,6 +30,10 @@ sha256sums=('578ed860a99a02cf1cf963efac830eb8af08093e4322832b2be6554d8c922ff2')
build() {
cd "$pkgbase-$pkgver"
+ # Build docs
+ ## Needs to happen before cmake runs
+ ruby -C doc -Ku docgen.rb mangen
+
# Build main library/application
mkdir -p build
env -C build cmake \
@@ -43,9 +47,6 @@ build() {
../src
make -C build
- # Build docs
- ruby -C doc -Ku docgen.rb mangen
-
# Build misc utils
## waybridge is disabled on VIDEO_PLATFORM=sdl
## leddec and ltui are missing install rules, so build with install RPATH
@@ -87,7 +88,7 @@ package_arcan-acfgfs() {
}
package_arcan-aclip() {
- pkgdesc='Arcan clipboard integration, similarly to how 'xclip' works for Xorg'
+ pkgdesc='Arcan clipboard integration, similarly to how "xclip" works for Xorg'
depends=('arcan')
cd "$pkgbase-$pkgver"
diff --git a/arcan.sh b/arcan.sh
deleted file mode 100644
index 32da46124c5a..000000000000
--- a/arcan.sh
+++ /dev/null
@@ -1,12 +0,0 @@
-
-ARCAN_RESOURCEPATH=/usr/share/arcan/resources
-#ARCAN_FONTPATH=/usr/share/arcan/resources/fonts
-#ARCAN_BINPATH=/usr/bin
-ARCAN_STATEPATH=~/.arcan
-ARCAN_APPLSTOREPATH=~/.config/arcan/appl
-ARCAN_LIBPATH=/usr/lib
-ARCAN_LOGPATH=~/tmp
-# ARCAN_VIDEO_DEVICE=
-# ARCAN_INPUT_SCANDIR=
-# ARCAN_INPUT_TTYOVERRIDE
-# ARCAN_INPUT_DISABLE_TTYPSWAP