summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJens Staal2016-05-31 06:55:59 +0200
committerJens Staal2016-05-31 06:55:59 +0200
commit47e2b986b1daabb92c50443441fa92545adec178 (patch)
tree67584272496e52d5b52d8cf2026cf6c6eb555c5d
downloadaur-47e2b986b1daabb92c50443441fa92545adec178.tar.gz
first version or arcan
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD51
2 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b31633fbfd89
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+# Generated by mksrcinfo v8
+# Tue May 31 04:55:35 UTC 2016
+pkgbase = arcan
+ pkgdesc = Game Engine meets a Display Server meets a Multimedia Framework
+ pkgver = 0.5.0.r24.gb9f3e35
+ pkgrel = 1
+ url = http://arcan-fe.com
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = BSD
+ makedepends = cmake
+ makedepends = git
+ depends = sdl
+ depends = openal
+ depends = mesa
+ depends = freetype2
+ depends = sqlite
+ depends = lua
+ options = !libtool
+ options = !strip
+ options = !makeflags
+ options = !buildflags
+ options = staticlibs
+ source = git://github.com/letoram/arcan.git
+ sha256sums = SKIP
+
+pkgname = arcan
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b9f3703f88c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Mantainer Jens Staal <staal1978@gmail.com>
+
+pkgname=arcan
+pkgver=0.5.0.r24.gb9f3e35
+pkgrel=1
+pkgdesc="Game Engine meets a Display Server meets a Multimedia Framework"
+arch=('i686' 'x86_64')
+url="http://arcan-fe.com"
+license=('GPL' 'BSD')
+
+depends=('sdl' 'openal' 'mesa' 'freetype2' 'sqlite' 'lua')
+makedepends=('cmake' 'git')
+
+source=('git://github.com/letoram/arcan.git')
+
+sha256sums=('SKIP')
+
+options=('!libtool' '!strip' '!makeflags' '!buildflags' 'staticlibs')
+
+pkgver() {
+ cd "$srcdir"/$pkgname
+
+ if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ else
+ echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ fi
+}
+
+prepare() {
+ cd "$srcdir"/$pkgname
+ rm -rf build
+ mkdir build
+}
+
+build() {
+ cd "$srcdir"/$pkgname/build
+ # change Release to Debug if testing
+ cmake -DCMAKE_BUILD_TYPE="Release" -DVIDEO_PLATFORM=sdl ../src
+ make -j 12
+}
+
+
+package() {
+ cd "$srcdir"/$pkgname/build
+ cmake -E cmake_echo_color --cyan "Install the project..."
+ DESTDIR="$pkgdir" cmake -DCMAKE_INSTALL_PREFIX="/usr" -P cmake_install.cmake
+}
+
+
+