summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2020-08-04 00:30:46 +0100
committerWorMzy Tykashi2020-08-04 00:30:46 +0100
commit837f182a2584e90ceede88d6b7035856fc4d6566 (patch)
tree53267630eb14eba5740d43af2873677594a64d3a
downloadaur-837f182a2584e90ceede88d6b7035856fc4d6566.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
-rw-r--r--arcane_fortune15
-rw-r--r--arcanefortune.install8
4 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aee871aac7fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = arcanefortune
+ pkgdesc = A game of empire building, diplomacy, conquest, construction, and deconstruction
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://arcanefortune.com
+ install = arcanefortune.install
+ arch = x86_64
+ license = CC BY-NC-SA 4.0
+ options = !strip
+ options = !emptydirs
+ source = https://arcanefortune.com/releases/arcane_fortune_v0_1_0_linux.zip
+ source = arcane_fortune
+ sha512sums = ca81299acceb6a4fb4744dd7618f852ca02b12db6b1bccc6c62cd75bcbb50ac5ec89349bd06d8763596148adac69c02cf87cbd549e3cba74bab7304b9513198e
+ sha512sums = 52fab1757d298fe1d78596ad7965a618c1bebca2094be377e33cd10c5aa66a37ed6eb9bb3ea1a36f204946656e1ac5b4eab3c993b6a30e9a90f91d3661090d5a
+
+pkgname = arcanefortune
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba50ef419ce8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: WorMzy Tykashi <wormzy.tykashi@gmail.com>
+# PKGBUILD/install/wrapper all shamelessly ripped off from [community]/dwarffortress
+
+pkgname=arcanefortune
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="A game of empire building, diplomacy, conquest, construction, and deconstruction"
+arch=('x86_64')
+url="https://arcanefortune.com"
+license=('CC BY-NC-SA 4.0')
+options=(!strip !emptydirs)
+install=arcanefortune.install
+source=("${url}/releases/arcane_fortune_v${pkgver//./_}_linux.zip"
+ arcane_fortune)
+
+sha512sums=('ca81299acceb6a4fb4744dd7618f852ca02b12db6b1bccc6c62cd75bcbb50ac5ec89349bd06d8763596148adac69c02cf87cbd549e3cba74bab7304b9513198e'
+ '52fab1757d298fe1d78596ad7965a618c1bebca2094be377e33cd10c5aa66a37ed6eb9bb3ea1a36f204946656e1ac5b4eab3c993b6a30e9a90f91d3661090d5a')
+
+package() {
+ install -dm755 "${pkgdir}/opt"
+ install -Dm755 arcane_fortune "${pkgdir}/usr/bin/arcane_fortune"
+ cp -r "${srcdir}/arcane_fortune_v${pkgver//./_}_linux" "${pkgdir}/opt/arcanefortune"
+ install -Dm644 "${srcdir}/arcane_fortune_v${pkgver//./_}_linux/readme.txt" "${pkgdir}/usr/share/licenses/${pkgname}/readme.txt"
+}
diff --git a/arcane_fortune b/arcane_fortune
new file mode 100644
index 000000000000..82027aa6a8cf
--- /dev/null
+++ b/arcane_fortune
@@ -0,0 +1,15 @@
+#!/bin/sh
+
+# Game has limited knowledge of terms, "xterm", "xterm-256color" and "linux" should be safe
+#export TERM=linux
+pkgname=arcanefortune
+
+if [[ ! -d "${HOME}/.${pkgname}" ]]; then
+ mkdir -p "${HOME}/.${pkgname}/saves"
+ ln -s /opt/"${pkgname}"/nn "${HOME}/.${pkgname}/nn"
+ ln -s /opt/"${pkgname}"/arcane_fortune "${HOME}/.${pkgname}/arcane_fortune"
+ cp -rn /opt/"${pkgname}"/config "${HOME}/.${pkgname}/config"
+fi
+
+cd "${HOME}/.${pkgname}"
+exec ./arcane_fortune "${@}"
diff --git a/arcanefortune.install b/arcanefortune.install
new file mode 100644
index 000000000000..787a636e97ce
--- /dev/null
+++ b/arcanefortune.install
@@ -0,0 +1,8 @@
+post_upgrade() {
+ echo "You might have delete your ~/.arcanefortune directory to get the new file layout."
+ echo "Of course, you can backup your saves."
+}
+
+post_install() {
+ post_upgrade
+}