diff options
author | Doug Newgard | 2015-04-23 23:30:14 -0500 |
---|---|---|
committer | Doug Newgard | 2015-04-23 23:30:14 -0500 |
commit | 1be42da3fc6a05e343639bf0f5f9563233b615ce (patch) | |
tree | e18f301214af974cf803a6f0827d8f6d3ea731f5 | |
parent | bca7e8b2a115c1a3fa90291d4243e0d020be0ae6 (diff) | |
download | aur-1be42da3fc6a05e343639bf0f5f9563233b615ce.tar.gz |
Rewrite
-rw-r--r-- | .SRCINFO | 9 | ||||
-rw-r--r-- | PKGBUILD | 35 | ||||
-rw-r--r-- | arcanist.install | 5 |
3 files changed, 21 insertions, 28 deletions
@@ -1,14 +1,15 @@ pkgbase = arcanist-git - pkgdesc = Arcanist (commonly, "arc") is the command-line frontend to Phabricator - pkgver = conduit.5.693.ge4b1e8e + pkgdesc = The command-line frontend to Phabricator, commonly called arc + pkgver = 6.r828.g9ddf37b pkgrel = 1 url = http://phabricator.com - install = arcanist.install arch = any license = Apache makedepends = git depends = libphutil-git - provides = arcanist + depends = python + provides = arcanist=6.r828.g9ddf37b + conflicts = arcanist source = git://github.com/facebook/arcanist.git sha256sums = SKIP @@ -1,34 +1,31 @@ -# Maintainer: Sergio Correia <sergio@correia.cc> +# Maintainer: Doug Newgard <scimmia at archlinux dot info> +# Contributor: Sergio Correia <sergio@correia.cc> # Contributor: Nicolas Vivet <nizzox@gmail.com> -pkgname=arcanist-git _pkgname=arcanist -pkgver=conduit.5.693.ge4b1e8e +pkgname=$_pkgname-git +pkgver=6.r828.g9ddf37b pkgrel=1 -pkgdesc='Arcanist (commonly, "arc") is the command-line frontend to Phabricator' +pkgdesc='The command-line frontend to Phabricator, commonly called arc' arch=('any') url="http://phabricator.com" license=('Apache') -depends=('libphutil-git') +depends=('libphutil-git' 'python') makedepends=('git') -provides=('arcanist') -install='arcanist.install' -source=('git://github.com/facebook/arcanist.git') +provides=("$_pkgname=$pkgver") +conflicts=("$_pkgname") +source=("git://github.com/facebook/$_pkgname.git") sha256sums=('SKIP') pkgver() { - cd "${_pkgname}" - git describe --always | sed 's|-|.|g' # Use the tag of the last commit + cd $_pkgname + git describe --tags --always | sed 's/^conduit-//;s/-/.r/;s/-/./' } package() { - install -Dd "${srcdir}"/usr/share/php/"${_pkgname}" "${pkgdir}"/etc/bash_completion.d "${pkgdir}"/usr/bin - - # do not copy hidden directories - mkdir -p "${pkgdir}"/usr/share/php/"${_pkgname}" - cp -a "${srcdir}"/"${_pkgname}"/* "${pkgdir}"/usr/share/php/"${_pkgname}"/ - ln -s ../../usr/share/php/"${_pkgname}"/resources/shell/bash-completion "${pkgdir}"/etc/bash_completion.d/"${_pkgname}" - ln -s ../share/php/"${_pkgname}"/bin/arc "${pkgdir}"/usr/bin/arc + install -d "$pkgdir/usr/share/php/$_pkgname" "$pkgdir/usr/bin" +# do not copy hidden directories + cp -a $_pkgname/* "$pkgdir/usr/share/php/$_pkgname/" + install -Dm644 $_pkgname/resources/shell/bash-completion "$pkgdir/usr/share/bash-completion/completions/arc" + ln -s ../share/php/$_pkgname/bin/arc "$pkgdir/usr/bin/arc" } - -# vim:set ts=2 sw=2 et: diff --git a/arcanist.install b/arcanist.install deleted file mode 100644 index 84d4a0209cef..000000000000 --- a/arcanist.install +++ /dev/null @@ -1,5 +0,0 @@ -post_install() { - echo "You must add the path /usr/share/php to the open_basedir variable" - echo "of your /etc/php/php.ini configuration file in order to execute" - echo "the arc command." -} |