summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph Lansdowne2021-04-05 23:47:32 +0100
committerJoseph Lansdowne2021-04-05 23:47:32 +0100
commit5292a49848fe0c4d372335e508a66c28924c6af5 (patch)
tree8111b50684ee36fce82556a8b83ca922fc172d3a
parentc8e6e2692a621bce2eaa1caa15bf27cd836e2d7a (diff)
downloadaur-5292a49848fe0c4d372335e508a66c28924c6af5.tar.gz
fix for Arch's upgraded dotnet packages
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e01255cd4261..65be213757c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = arcdps-log-manager
pkgdesc = Manager for Guild Wars 2 arcdps EVTC logs
pkgver = 1.0.2
- pkgrel = 2
+ pkgrel = 3
url = https://gw2scratch.com/tools/manager
arch = x86_64
license = MIT
makedepends = git
makedepends = mono-msbuild
- depends = dotnet-sdk
+ makedepends = dotnet-sdk>=5
+ makedepends = dotnet-sdk<6
+ depends = dotnet-runtime-3.1
depends = gtk3
source = git+https://github.com/gw2scratch/evtc.git#tag=manager-v1.0.2
source = arcdps-log-manager.desktop
diff --git a/PKGBUILD b/PKGBUILD
index 16690a01b120..1d61b5ae78f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Joseph Lansdowne <J49137@gmail.com>
pkgname=arcdps-log-manager
pkgver=1.0.2
-pkgrel=2
+pkgrel=3
pkgdesc="Manager for Guild Wars 2 arcdps EVTC logs"
arch=(x86_64)
url="https://gw2scratch.com/tools/manager"
license=(MIT)
-makedepends=(git mono-msbuild)
-depends=(dotnet-sdk gtk3)
+makedepends=(git mono-msbuild 'dotnet-sdk>=5' 'dotnet-sdk<6')
+depends=(dotnet-runtime-3.1 gtk3)
source=("git+https://github.com/gw2scratch/evtc.git#tag=manager-v$pkgver"
"$pkgname.desktop")
sha256sums=(SKIP
@@ -15,6 +15,8 @@ sha256sums=(SKIP
build () {
cd "$srcdir/evtc"
+ # https://wiki.archlinux.org/index.php/.NET_Core#SDK_specified_could_not_be_found
+ export MSBuildSDKsPath=$(echo /usr/share/dotnet/sdk/5.*/Sdks)
msbuild -target:Restore,Build ArcdpsLogManager.Gtk -p:Configuration=Release
}