summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-03-27 10:18:16 +0100
committerAlexander F. Rødseth2019-03-27 10:18:16 +0100
commit74e2ee0514d5d70f9eed34fe3f2e7d6556daf05d (patch)
treec0730b85e792bef461cf9c22ab312198f4ce16a2
downloadaur-74e2ee0514d5d70f9eed34fe3f2e7d6556daf05d.tar.gz
Move from [community] to AUR in connection with the spring cleaning
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD39
-rw-r--r--arch-bugs-fs.xml16
-rw-r--r--arch-bugs-t.xml16
-rw-r--r--arch-forum-a.xml20
-rw-r--r--arch-forum-c.xml20
-rw-r--r--arch-pkgs.xml15
-rw-r--r--arch-wiki.xml16
-rw-r--r--aur.xml17
9 files changed, 187 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ce3fa6168ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by mksrcinfo v8
+# Wed Mar 27 09:15:56 UTC 2019
+pkgbase = arch-firefox-search
+ pkgdesc = Firefox Arch search engines (AUR, Pkgs, BBS, Wiki, etc.)
+ pkgver = 0.8.2
+ pkgrel = 8
+ url = http://archlinux.org/
+ arch = any
+ license = GPL
+ depends = firefox
+ replaces = arch-firefox3-search
+ source = arch-bugs-fs.xml
+ source = arch-bugs-t.xml
+ source = arch-forum-a.xml
+ source = arch-forum-c.xml
+ source = arch-pkgs.xml
+ source = arch-wiki.xml
+ source = aur.xml
+ md5sums = df18835df1ea78bc3fc0e05f934b1e46
+ md5sums = 0226a317c8bf23feaa80e21d1706f2d5
+ md5sums = 4eaa3d26ac41077ee25b66127ad9ef0a
+ md5sums = 2435c34ea6a012fe08a8d17a051e5f80
+ md5sums = 403c346ce089ec56c2db67f9f3d87514
+ md5sums = dbb93d1e793b92252b69f65110b33c42
+ md5sums = bd0896ec148707b6980d23adc6015448
+
+pkgname = arch-firefox-search
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac0d8a0b63e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer:
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=arch-firefox-search
+pkgver=0.8.2
+pkgrel=8
+pkgdesc="Firefox Arch search engines (AUR, Pkgs, BBS, Wiki, etc.)"
+arch=('any')
+url="http://archlinux.org/"
+license=('GPL')
+depends=("firefox")
+replaces=('arch-firefox3-search')
+source=(arch-bugs-fs.xml
+ arch-bugs-t.xml
+ arch-forum-a.xml
+ arch-forum-c.xml
+ arch-pkgs.xml
+ arch-wiki.xml
+ aur.xml)
+md5sums=('df18835df1ea78bc3fc0e05f934b1e46'
+ '0226a317c8bf23feaa80e21d1706f2d5'
+ '4eaa3d26ac41077ee25b66127ad9ef0a'
+ '2435c34ea6a012fe08a8d17a051e5f80'
+ '403c346ce089ec56c2db67f9f3d87514'
+ 'dbb93d1e793b92252b69f65110b33c42'
+ 'bd0896ec148707b6980d23adc6015448')
+
+package() {
+# _ffver=`pacman -Q firefox | cut -f2 -d\ | cut -f1 -d-`
+# depends=("firefox>=${_ffver}" "firefox<=${_ffver/0/99}")
+
+ cd "${srcdir}"
+ local _prefix="${pkgdir}"/usr/lib/firefox/distribution/searchplugins/common
+
+ for i in ${source[@]}; do
+ install -D -m 0644 "${srcdir}"/$i ${_prefix}/$i
+ done
+}
diff --git a/arch-bugs-fs.xml b/arch-bugs-fs.xml
new file mode 100644
index 000000000000..4ac0d05ca062
--- /dev/null
+++ b/arch-bugs-fs.xml
@@ -0,0 +1,16 @@
+<SearchPlugin xmlns="http://www.mozilla.org/2006/browser/search/">
+<ShortName>ArchBugs (FS)</ShortName>
+<Description>Arch Linux Bugtracker by FS</Description>
+<InputEncoding>UTF-8</InputEncoding>
+<Image width="16" height="16">data:image/x-icon;base64,R0lGODlhEAAQAKUmABeS0BeS0RiS0ReT0BeT0ReT0hiT0RiT0hiU0huV0hyV0h2V0x2W0iOZ0ySZ
+1SSa1Caa1Cyd1S+e1jKf1jCg1jKg1jOg1zSh1zeh2Dei1zqk2Duk2Dql2T2l2T6l2UOo2UOo2kao
+2UWq20qr206t3E+t3P//////////////////////////////////////////////////////////
+/////////////////////////////////////////////yH5BAEKAD8ALAAAAAAQABAAAAZVwJ9w
+SCwahQbH8ch4LI2QBuc5pEgiGOoQc5mEqB+Qp6MBUUmjjaWSES1LFwVhTlgsE3PAgY4w0gNCAnRF
+dAREdAeHg0NzBUQDdAZEBgFzjI5PllpFQQA7</Image>
+<Url type="text/html" method="GET" template="https://bugs.archlinux.org/index.php">
+ <Param name="task_id" value="{searchTerms}"/>
+ <Param name="do" value="details"/>
+</Url>
+<SearchForm>https://bugs.archlinux.org/</SearchForm>
+</SearchPlugin>
diff --git a/arch-bugs-t.xml b/arch-bugs-t.xml
new file mode 100644
index 000000000000..a47026406fc5
--- /dev/null
+++ b/arch-bugs-t.xml
@@ -0,0 +1,16 @@
+<SearchPlugin xmlns="http://www.mozilla.org/2006/browser/search/">
+<ShortName>ArchBugs (text)</ShortName>
+<Description>Arch Linux Bugtracker by text</Description>
+<InputEncoding>UTF-8</InputEncoding>
+<Image width="16" height="16">data:image/x-icon;base64,R0lGODlhEAAQAKUmABeS0BeS0RiS0ReT0BeT0ReT0hiT0RiT0hiU0huV0hyV0h2V0x2W0iOZ0ySZ
+1SSa1Caa1Cyd1S+e1jKf1jCg1jKg1jOg1zSh1zeh2Dei1zqk2Duk2Dql2T2l2T6l2UOo2UOo2kao
+2UWq20qr206t3E+t3P//////////////////////////////////////////////////////////
+/////////////////////////////////////////////yH5BAEKAD8ALAAAAAAQABAAAAZVwJ9w
+SCwahQbH8ch4LI2QBuc5pEgiGOoQc5mEqB+Qp6MBUUmjjaWSES1LFwVhTlgsE3PAgY4w0gNCAnRF
+dAREdAeHg0NzBUQDdAZEBgFzjI5PllpFQQA7</Image>
+<Url type="text/html" method="GET" template="https://bugs.archlinux.org/index.php">
+ <Param name="string" value="{searchTerms}"/>
+ <Param name="project" value="0"/>
+</Url>
+<SearchForm>https://bugs.archlinux.org/</SearchForm>
+</SearchPlugin>
diff --git a/arch-forum-a.xml b/arch-forum-a.xml
new file mode 100644
index 000000000000..b7a89faaae56
--- /dev/null
+++ b/arch-forum-a.xml
@@ -0,0 +1,20 @@
+<SearchPlugin xmlns="http://www.mozilla.org/2006/browser/search/">
+<ShortName>ArchForum (author)</ShortName>
+<Description>Arch Linux Forums (by author)</Description>
+<InputEncoding>UTF-8</InputEncoding>
+<Image width="16" height="16">data:image/x-icon;base64,R0lGODlhEAAQAKUmABeS0BeS0RiS0ReT0BeT0ReT0hiT0RiT0hiU0huV0hyV0h2V0x2W0iOZ0ySZ
+1SSa1Caa1Cyd1S+e1jKf1jCg1jKg1jOg1zSh1zeh2Dei1zqk2Duk2Dql2T2l2T6l2UOo2UOo2kao
+2UWq20qr206t3E+t3P//////////////////////////////////////////////////////////
+/////////////////////////////////////////////yH5BAEKAD8ALAAAAAAQABAAAAZVwJ9w
+SCwahQbH8ch4LI2QBuc5pEgiGOoQc5mEqB+Qp6MBUUmjjaWSES1LFwVhTlgsE3PAgY4w0gNCAnRF
+dAREdAeHg0NzBUQDdAZEBgFzjI5PllpFQQA7</Image>
+<Url type="text/html" method="GET" template="https://bbs.archlinux.org/search.php">
+ <Param name="author" value="{searchTerms}"/>
+ <Param name="search_in" value="0"/>
+ <Param name="sort_by" value="0"/>
+ <Param name="sort_dir" value="DESC"/>
+ <Param name="show_as" value="posts"/>
+ <Param name="action" value="search"/>
+</Url>
+<SearchForm>https://bbs.archlinux.org/</SearchForm>
+</SearchPlugin>
diff --git a/arch-forum-c.xml b/arch-forum-c.xml
new file mode 100644
index 000000000000..ab49431eed6a
--- /dev/null
+++ b/arch-forum-c.xml
@@ -0,0 +1,20 @@
+<SearchPlugin xmlns="http://www.mozilla.org/2006/browser/search/">
+<ShortName>ArchForum (keywords)</ShortName>
+<Description>Arch Linux forums (by keywords)</Description>
+<InputEncoding>UTF-8</InputEncoding>
+<Image width="16" height="16">data:image/x-icon;base64,R0lGODlhEAAQAKUmABeS0BeS0RiS0ReT0BeT0ReT0hiT0RiT0hiU0huV0hyV0h2V0x2W0iOZ0ySZ
+1SSa1Caa1Cyd1S+e1jKf1jCg1jKg1jOg1zSh1zeh2Dei1zqk2Duk2Dql2T2l2T6l2UOo2UOo2kao
+2UWq20qr206t3E+t3P//////////////////////////////////////////////////////////
+/////////////////////////////////////////////yH5BAEKAD8ALAAAAAAQABAAAAZVwJ9w
+SCwahQbH8ch4LI2QBuc5pEgiGOoQc5mEqB+Qp6MBUUmjjaWSES1LFwVhTlgsE3PAgY4w0gNCAnRF
+dAREdAeHg0NzBUQDdAZEBgFzjI5PllpFQQA7</Image>
+<Url type="text/html" method="GET" template="https://bbs.archlinux.org/search.php">
+ <Param name="keywords" value="{searchTerms}"/>
+ <Param name="search_in" value="0"/>
+ <Param name="sort_by" value="0"/>
+ <Param name="sort_dir" value="DESC"/>
+ <Param name="show_as" value="posts"/>
+ <Param name="action" value="search"/>
+</Url>
+<SearchForm>https://bbs.archlinux.org/</SearchForm>
+</SearchPlugin>
diff --git a/arch-pkgs.xml b/arch-pkgs.xml
new file mode 100644
index 000000000000..506a71671979
--- /dev/null
+++ b/arch-pkgs.xml
@@ -0,0 +1,15 @@
+<SearchPlugin xmlns="http://www.mozilla.org/2006/browser/search/">
+<ShortName>ArchPkgs</ShortName>
+<Description>Arch Linux Packages</Description>
+<InputEncoding>UTF-8</InputEncoding>
+<Image width="16" height="16">data:image/x-icon;base64,R0lGODlhEAAQAKUmABeS0BeS0RiS0ReT0BeT0ReT0hiT0RiT0hiU0huV0hyV0h2V0x2W0iOZ0ySZ
+1SSa1Caa1Cyd1S+e1jKf1jCg1jKg1jOg1zSh1zeh2Dei1zqk2Duk2Dql2T2l2T6l2UOo2UOo2kao
+2UWq20qr206t3E+t3P//////////////////////////////////////////////////////////
+/////////////////////////////////////////////yH5BAEKAD8ALAAAAAAQABAAAAZVwJ9w
+SCwahQbH8ch4LI2QBuc5pEgiGOoQc5mEqB+Qp6MBUUmjjaWSES1LFwVhTlgsE3PAgY4w0gNCAnRF
+dAREdAeHg0NzBUQDdAZEBgFzjI5PllpFQQA7</Image>
+<Url type="text/html" method="GET" template="https://www.archlinux.org/packages/">
+ <Param name="q" value="{searchTerms}"/>
+</Url>
+<SearchForm>https://www.archlinux.org/</SearchForm>
+</SearchPlugin>
diff --git a/arch-wiki.xml b/arch-wiki.xml
new file mode 100644
index 000000000000..ce5bdbb7396c
--- /dev/null
+++ b/arch-wiki.xml
@@ -0,0 +1,16 @@
+<SearchPlugin xmlns="http://www.mozilla.org/2006/browser/search/">
+<ShortName>ArchWiki</ShortName>
+<Description>Arch Linux Wiki</Description>
+<InputEncoding>UTF-8</InputEncoding>
+<Image width="16" height="16">data:image/x-icon;base64,R0lGODlhEAAQAKUmABeS0BeS0RiS0ReT0BeT0ReT0hiT0RiT0hiU0huV0hyV0h2V0x2W0iOZ0ySZ
+1SSa1Caa1Cyd1S+e1jKf1jCg1jKg1jOg1zSh1zeh2Dei1zqk2Duk2Dql2T2l2T6l2UOo2UOo2kao
+2UWq20qr206t3E+t3P//////////////////////////////////////////////////////////
+/////////////////////////////////////////////yH5BAEKAD8ALAAAAAAQABAAAAZVwJ9w
+SCwahQbH8ch4LI2QBuc5pEgiGOoQc5mEqB+Qp6MBUUmjjaWSES1LFwVhTlgsE3PAgY4w0gNCAnRF
+dAREdAeHg0NzBUQDdAZEBgFzjI5PllpFQQA7</Image>
+<Url type="text/html" method="GET" template="https://wiki.archlinux.org/index.php/Special:Search">
+ <Param name="search" value="{searchTerms}"/>
+ <Param name="fulltext" value="Search"/>
+</Url>
+<SearchForm>https://wiki.archlinux.org/</SearchForm>
+</SearchPlugin>
diff --git a/aur.xml b/aur.xml
new file mode 100644
index 000000000000..423febdcef81
--- /dev/null
+++ b/aur.xml
@@ -0,0 +1,17 @@
+<SearchPlugin xmlns="http://www.mozilla.org/2006/browser/search/">
+<ShortName>AUR</ShortName>
+<Description>AUR</Description>
+<InputEncoding>UTF-8</InputEncoding>
+<Image width="16" height="16">data:image/x-icon;base64,R0lGODlhEAAQAKUmABeS0BeS0RiS0ReT0BeT0ReT0hiT0RiT0hiU0huV0hyV0h2V0x2W0iOZ0ySZ
+1SSa1Caa1Cyd1S+e1jKf1jCg1jKg1jOg1zSh1zeh2Dei1zqk2Duk2Dql2T2l2T6l2UOo2UOo2kao
+2UWq20qr206t3E+t3P//////////////////////////////////////////////////////////
+/////////////////////////////////////////////yH5BAEKAD8ALAAAAAAQABAAAAZVwJ9w
+SCwahQbH8ch4LI2QBuc5pEgiGOoQc5mEqB+Qp6MBUUmjjaWSES1LFwVhTlgsE3PAgY4w0gNCAnRF
+dAREdAeHg0NzBUQDdAZEBgFzjI5PllpFQQA7</Image>
+<Url type="text/html" method="GET" template="https://aur.archlinux.org/packages.php">
+ <Param name="K" value="{searchTerms}"/>
+ <Param name="O" value="0"/>
+ <Param name="do_Search" value="Go"/>
+</Url>
+<SearchForm>https://aur.archlinux.org/</SearchForm>
+</SearchPlugin>