summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormehani2007-04-17 12:20:47 +0000
committermehani2007-04-17 12:20:47 +0000
commitdb20952019c1d48cdf69f55c22f1265e591cbe40 (patch)
tree0ccbe478b2b6d460ae6c0baeb5819e1976a60e82
downloadaur-db20952019c1d48cdf69f55c22f1265e591cbe40.tar.gz
New theme based on arch-gdm-theme at
http://aur.archlinux.org/packages/arch-gdm-theme/ git-svn-id: svn+ssh://scm.narf.ssji.net/svn/archlinux-packages@65 df209809-8e4a-0410-9a64-c169741eb0fc
-rw-r--r--.SRCINFO9
-rw-r--r--GdmGreeterTheme.desktop11
-rw-r--r--PKGBUILD28
-rw-r--r--arch-gdm-theme-list-0.1-1.pkg.tar.gzbin0 -> 177243 bytes
-rw-r--r--arch-list.xml147
-rw-r--r--arch.xml147
-rw-r--r--background.pngbin0 -> 51952 bytes
-rw-r--r--help.pngbin0 -> 2549 bytes
-rw-r--r--list.patch47
-rw-r--r--nvidia-arch.pngbin0 -> 110977 bytes
-rw-r--r--options.pngbin0 -> 3070 bytes
-rw-r--r--screenshot.jpgbin0 -> 10719 bytes
12 files changed, 389 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bb38dc8a8703
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,9 @@
+pkgbase = arch-gdm-theme-list
+ pkgdesc = An Arch Linux Theme for GDM, also with the face browser version
+ pkgver = 0.1
+ pkgrel = 1
+ makedepends = bash
+ depends = gdm
+
+pkgname = arch-gdm-theme-list
+
diff --git a/GdmGreeterTheme.desktop b/GdmGreeterTheme.desktop
new file mode 100644
index 000000000000..5b5584c9b2b9
--- /dev/null
+++ b/GdmGreeterTheme.desktop
@@ -0,0 +1,11 @@
+# This is not really a .desktop file like the rest, but it's useful to treat
+# it as such
+
+[GdmGreeterTheme]
+Encoding=UTF-8
+Greeter=arch.xml
+Name=Archlinux
+Description=Arch Linux GDM Theme
+Author=Lukas Kropatschek <lukas.krop@gmail.com
+Copyright=(c) 2006 Lukas Kropatschek
+Screenshot=screenshot.png
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e0f5fb32118
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Contributor: Olivier Mehani <olivier.mehani@inria.fr>
+# $Id$
+
+pkgname=arch-gdm-theme-list
+pkgver=0.1
+pkgrel=1
+pkgdesc="An Arch Linux Theme for GDM, also with the face browser version"
+makedepends=('bash')
+depends=('gdm')
+source=()
+
+build() {
+ mkdir -p $startdir/pkg/opt/gnome/share/gdm/themes/arch/
+ cp $startdir/arch.xml $startdir/pkg/opt/gnome/share/gdm/themes/arch/
+ cp $startdir/background.png $startdir/pkg/opt/gnome/share/gdm/themes/arch/
+ cp $startdir/options.png $startdir/pkg/opt/gnome/share/gdm/themes/arch/
+ cp $startdir/help.png $startdir/pkg/opt/gnome/share/gdm/themes/arch/
+ cp $startdir/screenshot.jpg $startdir/pkg/opt/gnome/share/gdm/themes/arch/
+ cp $startdir/GdmGreeterTheme.desktop $startdir/pkg/opt/gnome/share/gdm/themes/arch/
+ cp $startdir/nvidia-arch.png $startdir/pkg/opt/gnome/share/gdm/themes/arch/
+
+ mkdir -p $startdir/pkg/opt/gnome/share/gdm/themes/arch-list
+ for FILE in $startdir/pkg/opt/gnome/share/gdm/themes/arch/* ; do
+ BASENAME=${FILE/*\/}
+ ln -s /opt/gnome/share/gdm/themes/arch/${BASENAME} $startdir/pkg/opt/gnome/share/gdm/themes/arch-list/${BASENAME}
+ done
+ rm /opt/gnome/share/gdm/themes/arch/arch.xml
+}
diff --git a/arch-gdm-theme-list-0.1-1.pkg.tar.gz b/arch-gdm-theme-list-0.1-1.pkg.tar.gz
new file mode 100644
index 000000000000..f20beef35853
--- /dev/null
+++ b/arch-gdm-theme-list-0.1-1.pkg.tar.gz
Binary files differ
diff --git a/arch-list.xml b/arch-list.xml
new file mode 100644
index 000000000000..d78d9f15d8d6
--- /dev/null
+++ b/arch-list.xml
@@ -0,0 +1,147 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE greeter SYSTEM "greeter.dtd">
+<greeter>
+ <item type="svg">
+ <normal file="background.png"/>
+ <pos x="0" y="0" width="100%" height="100%"/>
+ </item>
+ <item type="rect">
+ <normal color="#000000"/>
+ <pos x="0" y="-75" width="100%" height="75"/>
+ <fixed>
+ <item type="rect">
+ <normal color="#ffffff"/>
+ <pos x="0" y="4" width="100%" height="100%"/>
+ <box orientation="horizontal" spacing="10" xpadding="10">
+ <item type="rect" id="options_button" button="true">
+ <normal color="#ffffff"/>
+ <pos y="50%" anchor="w" width="box" height="box"/>
+ <box orientation="horizontal" spacing="10" xpadding="10">
+ <item type="pixmap">
+ <normal file="options.png" tint="#dddddd"/>
+ <prelight file="options.png"/>
+ <active file="options.png" tint="#ff0000"/>
+ <pos y="50%" anchor="w"/>
+ </item>
+ <item type="label">
+ <normal color="#000000" font="Sans 12"/>
+ <prelight color="#666666" font="Sans 12"/>
+ <active color="#ff0000" font="Sans 12"/>
+ <pos y="50%" anchor="w"/>
+ <!-- Stock label for: _Options -->
+ <stock type="options"/>
+ </item>
+ </box>
+ </item>
+ </box>
+ </item>
+ </fixed>
+ </item>
+ <item type="pixmap">
+ <normal file="nvidia-arch.png"/>
+ <pos x="100%" y="100%" anchor="se"/>
+ </item>
+ <item type="label" id="clock">
+ <normal color="#000000" font="Sans 12"/>
+ <pos x="-20" y="-37" anchor="e"/>
+ <text>%c</text>
+ </item>
+
+ <item type="rect" id="caps-lock-warning">
+ <normal color="#FFFFFF" alpha="0.5"/>
+ <pos anchor="c" x="50%" y="75%" width="box" height="box"/>
+ <box orientation="vertical" min-width="400" xpadding="10" ypadding="5" spacing="0">
+ <item type="label">
+ <normal color="#000000" font="Sans 12"/>
+ <pos x="50%" anchor="n"/>
+ <!-- Stock label for: You've got capslock on! -->
+ <stock type="caps-lock-warning"/>
+ </item>
+ </box>
+ </item>
+
+ <item type="rect">
+ <show type="timed"/>
+ <normal color="#FFFFFF" alpha="0.5"/>
+ <pos anchor="c" x="50%" y="25%" width="box" height="box"/>
+ <box orientation="vertical" min-width="400" xpadding="10" ypadding="5" spacing="0">
+ <item type="label" id="timed-label">
+ <normal color="#000000" font="Sans 12"/>
+ <pos x="50%" anchor="n"/>
+ <!-- Stock label for: User %s will login in %d seconds -->
+ <stock type="timed-label"/>
+ </item>
+ </box>
+ </item>
+
+ <item type="rect">
+ <normal color="#FFFFFF" alpha="0.5"/>
+ <pos anchor="c" x="50%" y="50%" width="box" height="box"/>
+ <box orientation="vertical" min-width="340" xpadding="30" ypadding="30" spacing="10">
+ <item type="label">
+ <pos anchor="n" x="50%"/>
+ <normal color="#000000" font="Sans 14"/>
+ <!-- Stock label for: Welcome to %h -->
+ <stock type="welcome-label"/>
+ </item>
+ <item type="label" id="pam-prompt">
+ <pos anchor="nw" x="10%"/>
+ <normal color="#000000" font="Sans 12"/>
+ <!-- Stock label for: Username: -->
+ <stock type="username-label"/>
+ </item>
+ <item type="rect">
+ <normal color="#000000"/>
+ <pos anchor="n" x="50%" height="24" width="80%"/>
+ <fixed>
+ <item type="entry" id="user-pw-entry">
+ <normal color="#000000" font="Sans 12"/>
+ <pos anchor="nw" x="1" y="1" height="-2" width="-2"/>
+ </item>
+ </fixed>
+ </item>
+ <item type="rect" id="ok_button" button="true">
+ <normal color="#ffffff"/>
+ <pos anchor="n" x="50%" width="50%" height="20"/>
+ <box orientation="vertical" spacing="10" xpadding="10">
+ <item type="label">
+ <normal color="#000000" font="Sans 12"/>
+ <prelight color="#666666" font="Sans 12"/>
+ <active color="#ff0000" font="Sans 12"/>
+ <pos anchor="n" x="50%" height="24" width="50%"/>
+ <!-- Stock label for: _OK -->
+ <stock type="ok"/>
+ </item>
+ </box>
+ </item>
+ <item type="rect" id="cancel_button" button="true">
+ <normal color="#ffffff"/>
+ <pos anchor="n" x="50%" width="50%" height="20"/>
+ <box orientation="vertical" spacing="10" xpadding="10">
+ <item type="label">
+ <normal color="#000000" font="Sans 12"/>
+ <prelight color="#666666" font="Sans 12"/>
+ <active color="#ff0000" font="Sans 12"/>
+ <pos anchor="n" x="50%" height="24" width="50%"/>
+ <!-- Stock label for: _Cancel -->
+ <stock type="cancel"/>
+ </item>
+ </box>
+ </item>
+ <item type="label" id="pam-message">
+ <pos anchor="n" x="50%"/>
+ <normal color="#000000" font="Sans 12"/>
+ <text></text>
+ </item>
+ </box>
+ <fixed>
+ <item type="label" id="pam-error">
+ <pos anchor="n" x="50%" y="110%"/>
+ <normal color="#000000" font="Sans 12"/>
+ <text></text>
+ </item>
+ </fixed>
+ </item>
+</greeter>
+
+
diff --git a/arch.xml b/arch.xml
new file mode 100644
index 000000000000..d78d9f15d8d6
--- /dev/null
+++ b/arch.xml
@@ -0,0 +1,147 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE greeter SYSTEM "greeter.dtd">
+<greeter>
+ <item type="svg">
+ <normal file="background.png"/>
+ <pos x="0" y="0" width="100%" height="100%"/>
+ </item>
+ <item type="rect">
+ <normal color="#000000"/>
+ <pos x="0" y="-75" width="100%" height="75"/>
+ <fixed>
+ <item type="rect">
+ <normal color="#ffffff"/>
+ <pos x="0" y="4" width="100%" height="100%"/>
+ <box orientation="horizontal" spacing="10" xpadding="10">
+ <item type="rect" id="options_button" button="true">
+ <normal color="#ffffff"/>
+ <pos y="50%" anchor="w" width="box" height="box"/>
+ <box orientation="horizontal" spacing="10" xpadding="10">
+ <item type="pixmap">
+ <normal file="options.png" tint="#dddddd"/>
+ <prelight file="options.png"/>
+ <active file="options.png" tint="#ff0000"/>
+ <pos y="50%" anchor="w"/>
+ </item>
+ <item type="label">
+ <normal color="#000000" font="Sans 12"/>
+ <prelight color="#666666" font="Sans 12"/>
+ <active color="#ff0000" font="Sans 12"/>
+ <pos y="50%" anchor="w"/>
+ <!-- Stock label for: _Options -->
+ <stock type="options"/>
+ </item>
+ </box>
+ </item>
+ </box>
+ </item>
+ </fixed>
+ </item>
+ <item type="pixmap">
+ <normal file="nvidia-arch.png"/>
+ <pos x="100%" y="100%" anchor="se"/>
+ </item>
+ <item type="label" id="clock">
+ <normal color="#000000" font="Sans 12"/>
+ <pos x="-20" y="-37" anchor="e"/>
+ <text>%c</text>
+ </item>
+
+ <item type="rect" id="caps-lock-warning">
+ <normal color="#FFFFFF" alpha="0.5"/>
+ <pos anchor="c" x="50%" y="75%" width="box" height="box"/>
+ <box orientation="vertical" min-width="400" xpadding="10" ypadding="5" spacing="0">
+ <item type="label">
+ <normal color="#000000" font="Sans 12"/>
+ <pos x="50%" anchor="n"/>
+ <!-- Stock label for: You've got capslock on! -->
+ <stock type="caps-lock-warning"/>
+ </item>
+ </box>
+ </item>
+
+ <item type="rect">
+ <show type="timed"/>
+ <normal color="#FFFFFF" alpha="0.5"/>
+ <pos anchor="c" x="50%" y="25%" width="box" height="box"/>
+ <box orientation="vertical" min-width="400" xpadding="10" ypadding="5" spacing="0">
+ <item type="label" id="timed-label">
+ <normal color="#000000" font="Sans 12"/>
+ <pos x="50%" anchor="n"/>
+ <!-- Stock label for: User %s will login in %d seconds -->
+ <stock type="timed-label"/>
+ </item>
+ </box>
+ </item>
+
+ <item type="rect">
+ <normal color="#FFFFFF" alpha="0.5"/>
+ <pos anchor="c" x="50%" y="50%" width="box" height="box"/>
+ <box orientation="vertical" min-width="340" xpadding="30" ypadding="30" spacing="10">
+ <item type="label">
+ <pos anchor="n" x="50%"/>
+ <normal color="#000000" font="Sans 14"/>
+ <!-- Stock label for: Welcome to %h -->
+ <stock type="welcome-label"/>
+ </item>
+ <item type="label" id="pam-prompt">
+ <pos anchor="nw" x="10%"/>
+ <normal color="#000000" font="Sans 12"/>
+ <!-- Stock label for: Username: -->
+ <stock type="username-label"/>
+ </item>
+ <item type="rect">
+ <normal color="#000000"/>
+ <pos anchor="n" x="50%" height="24" width="80%"/>
+ <fixed>
+ <item type="entry" id="user-pw-entry">
+ <normal color="#000000" font="Sans 12"/>
+ <pos anchor="nw" x="1" y="1" height="-2" width="-2"/>
+ </item>
+ </fixed>
+ </item>
+ <item type="rect" id="ok_button" button="true">
+ <normal color="#ffffff"/>
+ <pos anchor="n" x="50%" width="50%" height="20"/>
+ <box orientation="vertical" spacing="10" xpadding="10">
+ <item type="label">
+ <normal color="#000000" font="Sans 12"/>
+ <prelight color="#666666" font="Sans 12"/>
+ <active color="#ff0000" font="Sans 12"/>
+ <pos anchor="n" x="50%" height="24" width="50%"/>
+ <!-- Stock label for: _OK -->
+ <stock type="ok"/>
+ </item>
+ </box>
+ </item>
+ <item type="rect" id="cancel_button" button="true">
+ <normal color="#ffffff"/>
+ <pos anchor="n" x="50%" width="50%" height="20"/>
+ <box orientation="vertical" spacing="10" xpadding="10">
+ <item type="label">
+ <normal color="#000000" font="Sans 12"/>
+ <prelight color="#666666" font="Sans 12"/>
+ <active color="#ff0000" font="Sans 12"/>
+ <pos anchor="n" x="50%" height="24" width="50%"/>
+ <!-- Stock label for: _Cancel -->
+ <stock type="cancel"/>
+ </item>
+ </box>
+ </item>
+ <item type="label" id="pam-message">
+ <pos anchor="n" x="50%"/>
+ <normal color="#000000" font="Sans 12"/>
+ <text></text>
+ </item>
+ </box>
+ <fixed>
+ <item type="label" id="pam-error">
+ <pos anchor="n" x="50%" y="110%"/>
+ <normal color="#000000" font="Sans 12"/>
+ <text></text>
+ </item>
+ </fixed>
+ </item>
+</greeter>
+
+
diff --git a/background.png b/background.png
new file mode 100644
index 000000000000..0f41d0cbd802
--- /dev/null
+++ b/background.png
Binary files differ
diff --git a/help.png b/help.png
new file mode 100644
index 000000000000..a318b4eae8b2
--- /dev/null
+++ b/help.png
Binary files differ
diff --git a/list.patch b/list.patch
new file mode 100644
index 000000000000..950ef1be5b23
--- /dev/null
+++ b/list.patch
@@ -0,0 +1,47 @@
+--- arch.xml 2007-02-02 19:23:52.000000000 +0100
++++ arch-list.xml 2007-02-02 19:23:52.000000000 +0100
+@@ -33,7 +33,7 @@
+
+ <item type="rect" id="caps-lock-warning">
+ <normal color="#FFFFFF" alpha="0.5"/>
+- <pos anchor="c" x="50%" y="75%" width="box" height="box"/>
++ <pos anchor="c" x="75%" y="75%" width="box" height="box"/>
+ <box orientation="vertical" min-width="400" xpadding="10" ypadding="5" spacing="0">
+ <item type="label">
+ <normal color="#000000" font="Sans 12"/>
+@@ -47,7 +47,7 @@
+ <item type="rect">
+ <show type="timed"/>
+ <normal color="#FFFFFF" alpha="0.5"/>
+- <pos anchor="c" x="50%" y="25%" width="box" height="box"/>
++ <pos anchor="c" x="75%" y="25%" width="box" height="box"/>
+ <box orientation="vertical" min-width="400" xpadding="10" ypadding="5" spacing="0">
+ <item type="label" id="timed-label">
+ <normal color="#000000" font="Sans 12"/>
+@@ -58,13 +58,24 @@
+ </box>
+ </item>
+
++ <item type="rect" id="userlist-rect">
++ <normal color="#FFFFFF" alpha="0.5" font="Sans 14"/>
++ <pos anchor="c" x="25%" y="50%" width="box" height="box"/>
++ <box orientation="vertical" min-width="440" max-width="440" min-height="100" xpadding="4" ypadding="4" spacing="0">
++ <item type="list" id="userlist">
++ <pos anchor="nw" x="0" y="0" height="550" width="440"/>
++ <color iconcolor="#ACBFDD" labelcolor="#ACBFDD"/>
++ </item>
++ </box>
++ </item>
++
+ <item type="rect">
+ <normal color="#FFFFFF" alpha="0.5"/>
+- <pos anchor="c" x="50%" y="50%" width="box" height="box"/>
++ <pos anchor="c" x="75%" y="50%" width="box" height="box"/>
+ <box orientation="vertical" min-width="340" xpadding="30" ypadding="30" spacing="10">
+ <item type="label">
+ <pos anchor="n" x="50%"/>
+- <normal color="#000000" font="Sans 14"/>
++ <normal color="#000000" font="Sans 18"/>
+ <!-- Stock label for: Welcome to %h -->
+ <stock type="welcome-label"/>
+ </item>
diff --git a/nvidia-arch.png b/nvidia-arch.png
new file mode 100644
index 000000000000..cefc37e6dbeb
--- /dev/null
+++ b/nvidia-arch.png
Binary files differ
diff --git a/options.png b/options.png
new file mode 100644
index 000000000000..220b79f2dfc3
--- /dev/null
+++ b/options.png
Binary files differ
diff --git a/screenshot.jpg b/screenshot.jpg
new file mode 100644
index 000000000000..1305e05f0704
--- /dev/null
+++ b/screenshot.jpg
Binary files differ