summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwiemag2015-06-19 19:23:03 +0200
committerwiemag2015-06-19 19:23:03 +0200
commitbdbfdf02f2e8a94a62bc533ec720aec52f25fe68 (patch)
tree5a7f6c813e8eb4727de5d6827df7667cab21d388
downloadaur-bdbfdf02f2e8a94a62bc533ec720aec52f25fe68.tar.gz
AUR migration transfer
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f45501e2f7ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = arch-headless
+ pkgdesc = Modify your arch ISO for a headless (and keyboardless) computer.
+ pkgver = 1.10
+ pkgrel = 1
+ url = http://github.com/wiemag/arch-headless
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = squashfs-tools
+ depends = cdrkit
+ depends = coreutils
+ depends = grep
+ depends = which
+ source = https://github.com/wiemag/arch-headless/archive/v1.10.tar.gz
+ md5sums = 3f23216117f07a71735afdca6639d669
+
+pkgname = arch-headless
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a732e36fb5f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Wiesław Magusiak <w.magusiak@gmail.com>
+pkgname=arch-headless
+pkgver=1.10
+pkgrel=1
+pkgdesc="Modify your arch ISO for a headless (and keyboardless) computer."
+arch=('i686' 'x86_64')
+url="http://github.com/wiemag/arch-headless"
+license=('GPL')
+groups=()
+depends=('squashfs-tools' 'cdrkit' 'coreutils' 'grep' 'which')
+#squashfs-tools: unsquashfs, mksquashfs
+#cdrkit: genisoimage
+#coreutils: md5sum, echo, date
+#grep: grep
+#which: which
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(https://github.com/wiemag/arch-headless/archive/v${pkgver}.tar.gz)
+noextract=()
+md5sums=('3f23216117f07a71735afdca6639d669')
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/"
+ install -d -m 755 ${pkgdir}/usr/bin
+ install -m 755 ${pkgname} "${pkgdir}/usr/bin/${pkgname}"
+ install -d -m 755 ${pkgdir}/usr/share/man/man1
+ install -D -m 644 ${pkgname}.man ${pkgdir}/usr/share/man/man1/${pkgname}.1
+}