summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorberberman2020-09-30 08:01:43 +0800
committerberberman2020-09-30 08:01:43 +0800
commitcf376c65c7cb2dfd07f9db387d4872a350022b24 (patch)
tree71416512e34ca4e2d9074c6c628bd4eee692a34d
parent581a1c433d3b576ea0edb30b737d9168d3fde2c7 (diff)
downloadaur-cf376c65c7cb2dfd07f9db387d4872a350022b24.tar.gz
Add submit, update dependency
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d79533ad930..660a1168e8bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = arch-hs-git
pkgdesc = Generating PKGBUILD for hackage packages.
- pkgver = r105.73e92e7
+ pkgver = r139.a397720
pkgrel = 1
url = https://github.com/berberman/arch-hs
arch = x86_64
@@ -23,6 +23,7 @@ pkgbase = arch-hs-git
depends = haskell-polysemy
depends = haskell-colourista
depends = haskell-optparse-applicative
+ depends = haskell-csv
provides = arch-hs
conflicts = arch-hs
source = arch-hs::git+https://github.com/berberman/arch-hs.git
diff --git a/PKGBUILD b/PKGBUILD
index ef642288d6df..65fc319908ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: berberman <hatsue@typed.icu>
pkgname=arch-hs-git
-pkgver=r105.73e92e7
+pkgver=r139.a397720
pkgrel=1
pkgdesc="Generating PKGBUILD for hackage packages."
arch=('x86_64')
url="https://github.com/berberman/arch-hs"
license=('MIT')
-depends=('ghc-libs' 'haskell-aeson' 'haskell-req' 'haskell-hackage-db' 'haskell-megaparsec' 'haskell-algebraic-graphs' 'haskell-conduit' 'haskell-tar-conduit' 'haskell-conduit-extra' 'haskell-split' 'haskell-neat-interpolation' 'haskell-microlens' 'haskell-microlens-th' 'haskell-polysemy' 'haskell-colourista' 'haskell-optparse-applicative')
+depends=('ghc-libs' 'haskell-aeson' 'haskell-req' 'haskell-hackage-db' 'haskell-megaparsec' 'haskell-algebraic-graphs' 'haskell-conduit' 'haskell-tar-conduit' 'haskell-conduit-extra' 'haskell-split' 'haskell-neat-interpolation' 'haskell-microlens' 'haskell-microlens-th' 'haskell-polysemy' 'haskell-colourista' 'haskell-optparse-applicative' 'haskell-csv')
makedepends=('ghc' 'git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -48,6 +48,7 @@ build() {
_gen_comp
_gen_comp "-diff"
+ _gen_comp "-submit"
}
package() {
@@ -60,4 +61,5 @@ package() {
_install_comp
_install_comp "-diff"
+ _install_comp "-submit"
}