summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVianney le Clément de Saint-Marcq2013-05-25 18:14:06 +0200
committerVianney le Clément de Saint-Marcq2015-06-11 20:23:01 +0200
commit073c6f92e2fccf43fd7e7ef4d786900c309381d7 (patch)
tree2881f4ba4a712d3d38ca2dbfd28b5879382902ad
downloadaur-073c6f92e2fccf43fd7e7ef4d786900c309381d7.tar.gz
New package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
-rw-r--r--install6
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..465f04e227f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = arch-luks-suspend-git
+ pkgdesc = Lock encrypted root volume on suspend
+ pkgver = 20130525.g772d3d8
+ pkgrel = 1
+ url = https://github.com/vianney/arch-luks-suspend
+ install = install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = systemd
+ depends = cryptsetup
+ depends = mkinitcpio
+ backup = etc/systemd/system/systemd-suspend.service
+ source = git://github.com/vianney/arch-luks-suspend.git
+ md5sums = SKIP
+
+pkgname = arch-luks-suspend-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8fc7bf716c74
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Vianney le Clément de Saint-Marcq <vleclement AT gmail·com>
+_pkgname=arch-luks-suspend
+pkgname=$_pkgname-git
+pkgver=20130525.g772d3d8
+pkgrel=1
+pkgdesc="Lock encrypted root volume on suspend"
+arch=('any')
+url="https://github.com/vianney/arch-luks-suspend"
+license=('GPL3')
+depends=('systemd' 'cryptsetup' 'mkinitcpio')
+makedepends=('git')
+backup=('etc/systemd/system/systemd-suspend.service')
+install=install
+source=("git://github.com/vianney/$_pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ _date=$(git show -s --format='%ci' | cut -d' ' -f1 | sed 's/-//g')
+ _hash=$(git show -s --format='%h')
+ echo "$_date.g$_hash"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/install b/install
new file mode 100644
index 000000000000..b3f73fdc365c
--- /dev/null
+++ b/install
@@ -0,0 +1,6 @@
+post_install() {
+ echo "Enable the encrypt, shutdown, and suspend hooks in /etc/mkinitcpio.conf"
+ echo "and run mkinitcpio -p linux."
+}
+
+# vim:set ts=2 sw=2 et: