summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobin Candau2024-02-10 00:20:52 +0100
committerRobin Candau2024-02-10 00:20:52 +0100
commit2fda82f465d721917fa4fb8206d4e56fc7d9cd47 (patch)
treeb790f8b58281100b3f2fdd8c2c88bd72c1ebf553
parentf6966f2c85f845cae6e36d05be677bd3a43ecffc (diff)
downloadaur-2fda82f465d721917fa4fb8206d4e56fc7d9cd47.tar.gz
New upstream release
https://github.com/Antiz96/arch-update/releases/tag/v1.11.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD19
2 files changed, 10 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9cbcbce3b77f..451af7195ab7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = arch-update
pkgdesc = An update notifier/applier that assists you with important pre/post update tasks.
- pkgver = 1.10.1
- pkgrel = 2
+ pkgver = 1.11.0
+ pkgrel = 1
url = https://github.com/Antiz96/arch-update
arch = any
license = GPL-3.0-or-later
+ depends = bash
depends = pacman-contrib
depends = curl
depends = htmlq
@@ -16,9 +17,7 @@ pkgbase = arch-update
optdepends = vim: Default merge program for pacdiff
optdepends = sudo: Privilege elevation
optdepends = doas: Privilege elavation
- source = arch-update-1.10.1.tar.gz::https://github.com/Antiz96/arch-update/archive/v1.10.1.tar.gz
- source = fix_flatpak_updates_detection.patch::https://github.com/Antiz96/arch-update/commit/ec8a61c1add94877cce05f73b3ea9cf83f354b1a.patch
- sha256sums = 4cc4ccee9af80ec347c2d444e1ae43ce323cd05fd13d0d750f886fa190a78c85
- sha256sums = 029d84a448592287c5d3660a894fc23b0b32d251d97ccbb884760add0a59cbc6
+ source = arch-update-1.11.0.tar.gz::https://github.com/Antiz96/arch-update/archive/v1.11.0.tar.gz
+ sha256sums = 4cc738cdfe891fd847f03f0b61935a570b77792b813ce71ebc50a46509429ee1
pkgname = arch-update
diff --git a/PKGBUILD b/PKGBUILD
index 0e67c5306809..5afe19ae0e2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Robin Candau <antiz@archlinux.org>
pkgname=arch-update
-pkgver=1.10.1
-pkgrel=2
+pkgver=1.11.0
+pkgrel=1
pkgdesc="An update notifier/applier that assists you with important pre/post update tasks."
arch=('any')
url="https://github.com/Antiz96/arch-update"
license=('GPL-3.0-or-later')
-depends=('pacman-contrib' 'curl' 'htmlq' 'diffutils')
+depends=('bash' 'pacman-contrib' 'curl' 'htmlq' 'diffutils')
optdepends=('yay: AUR support'
'paru: AUR support'
'flatpak: Flatpak support'
@@ -15,17 +15,8 @@ optdepends=('yay: AUR support'
'vim: Default merge program for pacdiff'
'sudo: Privilege elevation'
'doas: Privilege elavation')
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
- "fix_flatpak_updates_detection.patch::https://github.com/Antiz96/arch-update/commit/ec8a61c1add94877cce05f73b3ea9cf83f354b1a.patch")
-sha256sums=('4cc4ccee9af80ec347c2d444e1ae43ce323cd05fd13d0d750f886fa190a78c85'
- '029d84a448592287c5d3660a894fc23b0b32d251d97ccbb884760add0a59cbc6')
-
-prepare() {
- cd "${pkgname}-${pkgver}"
- # Temporary patch to make the Flatpak packages updates detection more robust and avoid eventual false positives
- # See https://github.com/Antiz96/arch-update/pull/104
- patch -Np1 <"${srcdir}/fix_flatpak_updates_detection.patch"
-}
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('4cc738cdfe891fd847f03f0b61935a570b77792b813ce71ebc50a46509429ee1')
package() {
cd "${pkgname}-${pkgver}"