summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobin Candau2023-11-10 16:00:48 +0100
committerRobin Candau2023-11-10 16:00:48 +0100
commitd8d4ba9cf6a0cec34393ba1835c88ebcaa30a6b1 (patch)
tree2e30c9f8366edf38b7616e281f9ff390da5147ed
parentf07d681db6eb83e174314c6139c6ce96e9fadc5a (diff)
downloadaur-d8d4ba9cf6a0cec34393ba1835c88ebcaa30a6b1.tar.gz
New upstream release
New upstream feature: Add support for Flatpak packages https://github.com/Antiz96/arch-update/pull/54
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD5
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c615700ed774..5a2275c0e3f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = arch-update
pkgdesc = An update notifier/applier that assists you with important pre/post update tasks.
- pkgver = 1.5.7
+ pkgver = 1.6.0
pkgrel = 1
url = https://github.com/Antiz96/arch-update
arch = any
@@ -12,10 +12,11 @@ pkgbase = arch-update
depends = vim
optdepends = yay: AUR support
optdepends = paru: AUR support
+ optdepends = Flatpak: Flatpak support
optdepends = libnotify: Desktop notification support
optdepends = sudo: Privilege elevation
optdepends = doas: Privilege elavation
- source = arch-update-1.5.7.tar.gz::https://github.com/Antiz96/arch-update/archive/v1.5.7.tar.gz
- sha256sums = 74d268f5e8fa93894dbaf7791a948ab9777ad2468003c4518ec3573707d3e5f7
+ source = arch-update-1.6.0.tar.gz::https://github.com/Antiz96/arch-update/archive/v1.6.0.tar.gz
+ sha256sums = 6d995c2e078b1de50aded56c510366b867cda866d84145deb36d9e87fbcd1019
pkgname = arch-update
diff --git a/PKGBUILD b/PKGBUILD
index c0a961d5225d..4153bdd299bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Robin Candau <antiz@archlinux.org>
pkgname=arch-update
-pkgver=1.5.7
+pkgver=1.6.0
pkgrel=1
pkgdesc="An update notifier/applier that assists you with important pre/post update tasks."
arch=('any')
@@ -10,11 +10,12 @@ license=('GPL3')
depends=('pacman-contrib' 'curl' 'htmlq' 'diffutils' 'vim')
optdepends=('yay: AUR support'
'paru: AUR support'
+ 'Flatpak: Flatpak support'
'libnotify: Desktop notification support'
'sudo: Privilege elevation'
'doas: Privilege elavation')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('74d268f5e8fa93894dbaf7791a948ab9777ad2468003c4518ec3573707d3e5f7')
+sha256sums=('6d995c2e078b1de50aded56c510366b867cda866d84145deb36d9e87fbcd1019')
package() {
cd "${pkgname}-${pkgver}"