summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntiz (Robin C.)2022-11-26 04:25:34 +0100
committerAntiz (Robin C.)2022-11-26 04:25:34 +0100
commitdd81d1fb36f3a39d9db46b452eeb72365d5698f3 (patch)
treee9dc46d67a748b6c2a38aeea80750520796a9646
parent1105991e74c21a22ff9a7ddfaf99c23a79c0daf8 (diff)
downloadaur-dd81d1fb36f3a39d9db46b452eeb72365d5698f3.tar.gz
Bump to v1.4.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD15
2 files changed, 18 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 215b0fa52884..fac760b015ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,21 @@
pkgbase = arch-update
- pkgdesc = A clickeable icon that automatically changes to act as an update notifier/applier
- pkgver = 1.3.2
+ pkgdesc = An update notifier/applier that assists you with important pre/post update tasks.
+ pkgver = 1.4.0
pkgrel = 1
url = https://github.com/Antiz96/arch-update
arch = any
license = GPL3
depends = pacman-contrib
+ depends = curl
+ depends = hq
+ depends = diffutils
+ depends = vim
optdepends = yay: AUR support
optdepends = paru: AUR support
optdepends = libnotify: Desktop notification support
- source = arch-update-1.3.2.tar.gz::https://github.com/Antiz96/arch-update/archive/v1.3.2.tar.gz
- sha256sums = 586b2ce7ad7ea68ece22a9a0bfeda77e2c83ee67dd1fa1f2e55deabb9c820aa4
+ optdepends = sudo: Privilege elevation
+ optdepends = doas: Privilege elavation
+ source = arch-update-1.4.0::https://github.com/Antiz96/arch-update/archive/v1.4.0.tar.gz
+ sha256sums = dfd7e614cc57053f180e779f0f92851de2a7c0afd15526caad12e3741d5b6398
pkgname = arch-update
diff --git a/PKGBUILD b/PKGBUILD
index 88ef6a2aaf37..f6bf9b24e6cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
# Maintainer: Robin Candau <robincandau[at]protonmail[dot]com>
pkgname=arch-update
-pkgver=1.3.2
+pkgver=1.4.0
pkgrel=1
-pkgdesc="A clickeable icon that automatically changes to act as an update notifier/applier"
+pkgdesc="An update notifier/applier that assists you with important pre/post update tasks."
arch=('any')
url="https://github.com/Antiz96/arch-update"
license=('GPL3')
-depends=('pacman-contrib')
+depends=('pacman-contrib' 'curl' 'hq' 'diffutils' 'vim')
optdepends=('yay: AUR support'
'paru: AUR support'
- 'libnotify: Desktop notification support')
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('586b2ce7ad7ea68ece22a9a0bfeda77e2c83ee67dd1fa1f2e55deabb9c820aa4')
+ 'libnotify: Desktop notification support'
+ 'sudo: Privilege elevation'
+ 'doas: Privilege elavation')
+source=("${pkgname}-${pkgver}::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('dfd7e614cc57053f180e779f0f92851de2a7c0afd15526caad12e3741d5b6398')
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
-
make PREFIX=/usr DESTDIR="${pkgdir}" install
}