summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobin Candau2023-11-22 00:41:47 +0100
committerRobin Candau2023-11-22 00:41:47 +0100
commite952c94932849dbafff59e9622ec432f0275700e (patch)
treead83add2f474415e35338c2c6dff2e52427ddbde
parent5d2bfc5b5246bdd7fd428e4d95a292e0943cca08 (diff)
downloadaur-e952c94932849dbafff59e9622ec432f0275700e.tar.gz
New upstream release
Make vim an optional dependency
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dffc49fcecf5..da5f2923f703 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = arch-update
pkgdesc = An update notifier/applier that assists you with important pre/post update tasks.
- pkgver = 1.6.1
+ pkgver = 1.6.2
pkgrel = 1
url = https://github.com/Antiz96/arch-update
arch = any
@@ -9,14 +9,14 @@ pkgbase = arch-update
depends = curl
depends = htmlq
depends = diffutils
- depends = vim
optdepends = yay: AUR support
optdepends = paru: AUR support
optdepends = Flatpak: Flatpak support
optdepends = libnotify: Desktop notification support
+ optdepends = vim: Default merge program for pacdiff
optdepends = sudo: Privilege elevation
optdepends = doas: Privilege elavation
- source = arch-update-1.6.1.tar.gz::https://github.com/Antiz96/arch-update/archive/v1.6.1.tar.gz
- sha256sums = b2098276dacf8356df420dd7804714828b6a560307ed43e7c6ec395b432b1082
+ source = arch-update-1.6.2.tar.gz::https://github.com/Antiz96/arch-update/archive/v1.6.2.tar.gz
+ sha256sums = 34401752aae59ea46d0e01873fb7ae20c27be6995b372a8d4995716dabe22df5
pkgname = arch-update
diff --git a/PKGBUILD b/PKGBUILD
index 0636929864f0..615952f521ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
# Maintainer: Robin Candau <antiz@archlinux.org>
pkgname=arch-update
-pkgver=1.6.1
+pkgver=1.6.2
pkgrel=1
pkgdesc="An update notifier/applier that assists you with important pre/post update tasks."
arch=('any')
url="https://github.com/Antiz96/arch-update"
license=('GPL3')
-depends=('pacman-contrib' 'curl' 'htmlq' 'diffutils' 'vim')
+depends=('pacman-contrib' 'curl' 'htmlq' 'diffutils')
optdepends=('yay: AUR support'
'paru: AUR support'
'Flatpak: Flatpak support'
'libnotify: Desktop notification support'
+ 'vim: Default merge program for pacdiff'
'sudo: Privilege elevation'
'doas: Privilege elavation')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('b2098276dacf8356df420dd7804714828b6a560307ed43e7c6ec395b432b1082')
+sha256sums=('34401752aae59ea46d0e01873fb7ae20c27be6995b372a8d4995716dabe22df5')
package() {
cd "${pkgname}-${pkgver}"