summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobin Candau2024-02-07 20:53:26 +0100
committerRobin Candau2024-02-07 20:53:26 +0100
commitf6966f2c85f845cae6e36d05be677bd3a43ecffc (patch)
treeaceacaaa4113fa12b553059c82c1fbd24b0fc42f
parenta82dcbcda19d3f1fcf04167edbeb7c1716aeaddf (diff)
downloadaur-f6966f2c85f845cae6e36d05be677bd3a43ecffc.tar.gz
Add a patch to upstream issue #103 + Switch license to SPDX identifier
See https://github.com/Antiz96/arch-update/issues/103 & https://github.com/Antiz96/arch-update/pull/104
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 17 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3dc54b51a86e..9cbcbce3b77f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = arch-update
pkgdesc = An update notifier/applier that assists you with important pre/post update tasks.
pkgver = 1.10.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Antiz96/arch-update
arch = any
- license = GPL3
+ license = GPL-3.0-or-later
depends = pacman-contrib
depends = curl
depends = htmlq
@@ -17,6 +17,8 @@ pkgbase = arch-update
optdepends = sudo: Privilege elevation
optdepends = doas: Privilege elavation
source = arch-update-1.10.1.tar.gz::https://github.com/Antiz96/arch-update/archive/v1.10.1.tar.gz
+ source = fix_flatpak_updates_detection.patch::https://github.com/Antiz96/arch-update/commit/ec8a61c1add94877cce05f73b3ea9cf83f354b1a.patch
sha256sums = 4cc4ccee9af80ec347c2d444e1ae43ce323cd05fd13d0d750f886fa190a78c85
+ sha256sums = 029d84a448592287c5d3660a894fc23b0b32d251d97ccbb884760add0a59cbc6
pkgname = arch-update
diff --git a/PKGBUILD b/PKGBUILD
index 4b893acebe61..0e67c5306809 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
pkgname=arch-update
pkgver=1.10.1
-pkgrel=1
+pkgrel=2
pkgdesc="An update notifier/applier that assists you with important pre/post update tasks."
arch=('any')
url="https://github.com/Antiz96/arch-update"
-license=('GPL3')
+license=('GPL-3.0-or-later')
depends=('pacman-contrib' 'curl' 'htmlq' 'diffutils')
optdepends=('yay: AUR support'
'paru: AUR support'
@@ -15,8 +15,17 @@ optdepends=('yay: AUR support'
'vim: Default merge program for pacdiff'
'sudo: Privilege elevation'
'doas: Privilege elavation')
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('4cc4ccee9af80ec347c2d444e1ae43ce323cd05fd13d0d750f886fa190a78c85')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
+ "fix_flatpak_updates_detection.patch::https://github.com/Antiz96/arch-update/commit/ec8a61c1add94877cce05f73b3ea9cf83f354b1a.patch")
+sha256sums=('4cc4ccee9af80ec347c2d444e1ae43ce323cd05fd13d0d750f886fa190a78c85'
+ '029d84a448592287c5d3660a894fc23b0b32d251d97ccbb884760add0a59cbc6')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ # Temporary patch to make the Flatpak packages updates detection more robust and avoid eventual false positives
+ # See https://github.com/Antiz96/arch-update/pull/104
+ patch -Np1 <"${srcdir}/fix_flatpak_updates_detection.patch"
+}
package() {
cd "${pkgname}-${pkgver}"