summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobin Candau2022-03-30 21:55:43 +0200
committerRobin Candau2022-03-30 21:55:43 +0200
commitf9064fe3658f650480143b9a75c6b84fe6650242 (patch)
treeca7712901450d4e959facae76ef1ccee5495caaf
downloadaur-f9064fe3658f650480143b9a75c6b84fe6650242.tar.gz
Initial Release
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e92b37e2694b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = arch-update
+ pkgdesc = A clickeable icon that automatically changes to act as an update notifier/applier
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/Antiz96/arch-update
+ arch = any
+ license = GPL3
+ depends = pacman-contrib
+ optdepends = yay: AUR support
+ optdepends = libnotify: Desktop notification support
+ source = https://github.com/Antiz96/arch-update/raw/main/arch-update.tar.gz
+ sha256sums = 4d00fcb6c8f7dbceb9b97be2b2f190d59a5774c65978719db6daa75068ba8a8c
+
+pkgname = arch-update
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d99c7bfaa140
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Robin Candau <robincandau at protonmail dot com>
+pkgname=arch-update
+pkgver=1.0
+pkgrel=1
+pkgdesc="A clickeable icon that automatically changes to act as an update notifier/applier"
+arch=('any')
+url="https://github.com/Antiz96/arch-update"
+license=('GPL3')
+depends=('pacman-contrib')
+optdepends=('yay: AUR support'
+ 'libnotify: Desktop notification support'
+ )
+source=($url/raw/main/$pkgname.tar.gz)
+sha256sums=(4d00fcb6c8f7dbceb9b97be2b2f190d59a5774c65978719db6daa75068ba8a8c)
+
+package() {
+
+ cd "$srcdir"
+
+ install -Dm 755 "bin/$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
+
+ mkdir -p "$pkgdir/usr/share/icons/$pkgname"
+ install -Dm 666 "icons/$pkgname.svg" "$pkgdir/usr/share/icons/$pkgname/"
+ install -Dm 666 "icons/"$pkgname"_checking.svg" "$pkgdir/usr/share/icons/$pkgname/"
+ install -Dm 666 "icons/"$pkgname"_installing.svg" "$pkgdir/usr/share/icons/$pkgname/"
+ install -Dm 666 "icons/"$pkgname"_up-to-date.svg" "$pkgdir/usr/share/icons/$pkgname/"
+ install -Dm 666 "icons/"$pkgname"_updates-available.svg" "$pkgdir/usr/share/icons/$pkgname/"
+
+ install -Dm 644 "desktop/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+
+ install -Dm 644 "systemd/$pkgname.service" "$pkgdir/usr/lib/systemd/user/$pkgname.service"
+ install -Dm 644 "systemd/$pkgname.timer" "$pkgdir/usr/lib/systemd/user/$pkgname.timer"
+
+ install -Dm 644 "man/$pkgname.1.gz" "$pkgdir/usr/share/man/man1/$pkgname.1.gz"
+}