summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGregory Scheerlinck2016-02-05 20:24:13 +0000
committerGregory Scheerlinck2016-02-05 20:24:13 +0000
commit67df7d1fa1440b2962d5a88a4771f8528e731ab0 (patch)
tree7f6a79b45bc3974a936f37ddc685dde452c056bf
downloadaur-67df7d1fa1440b2962d5a88a4771f8528e731ab0.tar.gz
first commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a5f96bb6e69d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Fri Feb 5 20:23:30 UTC 2016
+pkgbase = awman
+ pkgdesc = The Arch Wiki as linux man pages
+ pkgver = 1.0.5
+ pkgrel = 1
+ url = https://github.com/greg-js/arch-wiki-man#readme
+ arch = any
+ license = GPL3
+ depends = nodejs
+ depends = npm
+ noextract = arch-wiki-man-1.0.5.tgz
+ source = http://registry.npmjs.org/arch-wiki-man/-/arch-wiki-man-1.0.5.tgz
+ sha1sums = 58210d19e1949e0a209c2c60b2bce3dbb0360a59
+
+pkgname = awman
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f066220bea2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Gregory Scheerlinck <gregory dot scheerlinck at gmail dot com>
+_npmname=arch-wiki-man
+_npmver=1.0.5
+pkgname=awman # All lowercase
+pkgver=1.0.5
+pkgrel=1
+pkgdesc="The Arch Wiki as linux man pages"
+arch=('any')
+url="https://github.com/greg-js/arch-wiki-man#readme"
+license=('GPL3')
+depends=('nodejs' 'npm')
+optdepends=()
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
+noextract=($_npmname-$_npmver.tgz)
+sha1sums=(58210d19e1949e0a209c2c60b2bce3dbb0360a59)
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+}
+
+# vim:set ts=2 sw=2 et: