summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValHue2017-01-25 21:54:17 +0100
committerValHue2017-01-25 21:54:17 +0100
commit1bf99847ff482f54fcb47b3da26361d8be7ccacf (patch)
treef7c2036e75877955a962cde454c40da07a541a05
downloadaur-1bf99847ff482f54fcb47b3da26361d8be7ccacf.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD54
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b84e1a89884b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = archalien-git
+ pkgdesc = A tool you can use to convert a Debian package .deb to an Arch Linux package.
+ pkgver = 19181e8
+ pkgrel = 1
+ url = https://github.com/Asher256/archalien
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = python
+ provides = archalien
+ source = git://github.com/Asher256/archalien
+ sha256sums = SKIP
+
+pkgname = archalien-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4903c8ea6709
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: ValHue <vhuelamo at gmail dot com>
+# https://github.com/ValHue/AUR-PKGBUILDs
+#
+_pkgname="archalien"
+pkgname="${_pkgname}"-git
+pkgver=19181e8
+pkgrel=1
+pkgdesc="A tool you can use to convert a Debian package .deb to an Arch Linux package."
+url="https://github.com/Asher256/archalien"
+license=('GPL2')
+arch=('i686' 'x86_64')
+depends=('python')
+makedepends=('git')
+provides=("${_pkgname}")
+source=("git://github.com/Asher256/${_pkgname}")
+sha256sums=('SKIP')
+
+_pkgname_bin="#! /usr/bin/python
+# -*- python -*-
+# -*- coding: utf-8 -*-
+
+from archalien.archalien import command_required, fix_input_pkg, usage, more_informations, handle_arguments, read_debcontrol, write_archcontrol, convert
+
+if __name__ == '__main__':
+ try:
+ command_required('ar', 'tar', 'find', 'sed')
+ DATA = handle_arguments()
+ convert(DATA['input_pkg'],
+ DATA['output_pkg'])
+ except KeyboardInterrupt:
+ print(\"Interrupted.\")
+
+# vim:ai:et:sw=4:ts=4:sts=4:tw=78:fenc=utf-8"
+
+_python3_version=$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')
+
+pkgver() {
+ cd "${_pkgname}"
+ git describe --always | sed 's|-|.|g' | sed 's|_|.|g' | cut -d'.' -f2-
+}
+
+build() {
+ cd "${_pkgname}"
+ echo -e "$_pkgname_bin" | tee ${_pkgname}_bin
+}
+
+package() {
+ cd "${_pkgname}"
+ install -m 755 -D ${_pkgname}_bin "${pkgdir}/usr/bin/${_pkgname}"
+ install -m 644 -D ${_pkgname}.py "${pkgdir}/usr/lib/python${_python3_version}/site-packages/${_pkgname}/${_pkgname}.py"
+ install -m 644 -D LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}
+
+# vim:set ts=4 sw=2 ft=sh et: