summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAtomicFS2024-05-04 15:40:06 +0200
committerAtomicFS2024-05-04 15:40:06 +0200
commit25d08669befd70b0fc1c2805411c0a0f025dc5cc (patch)
treee5d95dbda4dfac903e23393086bc96b48837f0e6
parentd2969d823a1d33834b7cf7dca89877b833a3948a (diff)
downloadaur-25d08669befd70b0fc1c2805411c0a0f025dc5cc.tar.gz
chore: cleanup
Signed-off-by: AtomicFS <vojtech_vesely@white-hat-hacker.icu>
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 28 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc526f09b29b..03883c7922e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,17 +5,17 @@ pkgbase = archarm-mobile-fde-installer-git
url = https://github.com/dreemurrs-embedded/archarm-mobile-fde-installer
arch = any
license = custom:none
- depends = parted
depends = cryptsetup
- depends = sudo
- depends = wget
- depends = tar
- depends = squashfs-tools
+ depends = curl
depends = e2fsprogs
depends = f2fs-tools
+ depends = parted
+ depends = squashfs-tools
+ depends = sudo
+ depends = tar
depends = util-linux
+ depends = wget
depends = zstd
- depends = curl
optdepends = gnupg: config import/export support
provides = archarm-mobile-fde-installer=1.0.0
source = git+https://github.com/dreemurrs-embedded/archarm-mobile-fde-installer.git
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index f71c635dafda..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-*
-!.gitignore
-!PKGBUILD
-!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index b50fc3083d21..42f39a713beb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,43 @@
# Maintainer: Dreemurrs Embedded Labs
+
pkgname=archarm-mobile-fde-installer-git
-pkgver=1.0.0
+_pkgname=${pkgname%-git}
+pkgver=r1.d2969d8
pkgrel=1
pkgdesc='Script to setup Full-Ddisk-Encryption on Arch Linux ARM for PinePhone and PineTab'
arch=('any')
url='https://github.com/dreemurrs-embedded/archarm-mobile-fde-installer'
license=('custom:none')
-depends=('git' 'openssl')
-optdepends=('gnupg: config import/export support')
+depends=(
+ 'git'
+ 'openssl'
+)
+optdepends=(
+ 'gnupg: config import/export support'
+)
source=("git+https://github.com/dreemurrs-embedded/archarm-mobile-fde-installer.git")
sha256sums=('SKIP')
provides=("archarm-mobile-fde-installer=${pkgver}")
depends=(
- 'parted'
'cryptsetup'
- 'sudo'
- 'wget'
- 'tar'
- 'squashfs-tools'
+ 'curl'
'e2fsprogs'
'f2fs-tools'
+ 'parted'
+ 'squashfs-tools'
+ 'sudo'
+ 'tar'
'util-linux'
+ 'wget'
'zstd'
- 'curl'
)
+pkgver() {
+ cd "${srcdir}/"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
package() {
- cd "archarm-mobile-fde-installer/"
+ cd "${srcdir}/${_pkgname}"
install -m 755 -D installer.sh "${pkgdir}/usr/bin/archarm-mobile-fde-installer"
}