summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTiago Koji Castro Shibata2018-03-28 19:40:26 -0300
committerTiago Koji Castro Shibata2018-03-28 19:40:34 -0300
commit8041aea8b0c764e88cd962f83d32312a63a59865 (patch)
tree2e9e0743039537c5fafdc973f0a84f068c9ab7b6
downloadaur-8041aea8b0c764e88cd962f83d32312a63a59865.tar.gz
Initial version
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--Makefile10
-rw-r--r--PKGBUILD33
4 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e20315553fe8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = archc-git
+ pkgdesc = A powerful and modern open-source architecture description language
+ pkgver = v0.1
+ pkgrel = 1
+ url = https://github.com/ArchC/ArchC
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = git
+ depends = systemc
+ provides = archc
+ conflicts = archc
+ source = git+https://github.com/ArchC/ArchC.git
+ md5sums = SKIP
+
+pkgname = archc-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ef1c516c0ef3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg*
+/ArchC
+/pkg
+/src
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..530ee439c38d
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+all: .SRCINFO
+
+.SRCINFO: PKGBUILD
+ makepkg --printsrcinfo > .SRCINFO
+
+test:
+ makepkg -sf
+ namcap archc-git-*.pkg*
+
+.PHONY: all clean test
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf3f9757438e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Tiago Koji Castro Shibata <tiago.shibata@gmail.com>
+pkgname=archc-git
+pkgver=2.4.1.r71.gf0b697c
+pkgrel=1
+pkgdesc='A powerful and modern open-source architecture description language'
+arch=('x86_64' 'i686')
+url='https://github.com/ArchC/ArchC'
+license=('GPL')
+depends=('bash')
+makedepends=('git' 'systemc')
+provides=('archc')
+conflicts=('archc')
+source=('git+https://github.com/ArchC/ArchC.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd ArchC
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd ArchC
+ ./autogen.sh
+ ./configure --prefix=$pkgdir/usr
+ make
+}
+
+package() {
+ cd ArchC
+ make install
+ # Move configuration files to /etc
+ mv $pkgdir/{usr/,}etc
+}