summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreenRaccoon232016-11-12 04:09:43 -0600
committerGreenRaccoon232016-11-12 04:09:43 -0600
commit7df12f438feccd5c48d2c1ee8849245a6966af82 (patch)
treebb23b4517bc533038ece7e164607c3d97ef9cb17
parentfcd6512af8508618e3fe2ce9fd736984300964c2 (diff)
downloadaur-7df12f438feccd5c48d2c1ee8849245a6966af82.tar.gz
Hopefully fixed md5sum problems
-rwxr-xr-x.SRCINFO7
-rwxr-xr-xPKGBUILD26
2 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41d3d71b0b18..7e0fae803eb3 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Nov 5 07:42:12 UTC 2016
+# Sat Nov 12 10:07:32 UTC 2016
pkgbase = archdroid-icon-theme
pkgdesc = Port of Android 5/6 (Lollipop/Marshmallow)'s material design icons to Arch.
pkgver = r114.ce01a58
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/GreenRaccoon23/archdroid-icon-theme
install = archdroid-icon-theme.install
arch = any
@@ -13,8 +13,9 @@ pkgbase = archdroid-icon-theme
makedepends = gtk-update-icon-cache
provides = archdroid-icon-theme
conflicts = archdroid-icon-theme
+ conflicts = archdroid-icon-theme-git
options = !strip
- source = https://github.com/GreenRaccoon23/archdroid-icon-theme/raw/master/archdroid-icon-theme.tar.xz
+ source = https://raw.githubusercontent.com/GreenRaccoon23/archdroid-icon-theme/master/archdroid-icon-theme.tar.xz
md5sums = db3cd391f7f1d7ed767b6cff4a85475c
pkgname = archdroid-icon-theme
diff --git a/PKGBUILD b/PKGBUILD
index 0acca72916d4..8a168a24981f 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,10 +12,10 @@
# In other words, choose this package over 'archdroid-icon-theme-git',
# unless you have a specific reason to download the other one
# (e.g., this package doesn't download correctly).
-#
+#
# To revert to an older version, use an archive here:
-# https://github.com/GreenRaccoon23/archdroid-icon-theme/raw/master/bak
-#
+# https://raw.githubusercontent.com/GreenRaccoon23/archdroid-icon-theme/raw/master/bak
+#
# Since this theme is comprised of svg images, it uses local fonts.
# The few icons which display text require the Roboto font.
# If you do not have Roboto installed but want to install this theme anyway,
@@ -23,19 +23,22 @@
pkgname=archdroid-icon-theme
pkgver=r114.ce01a58
-pkgrel=1
+pkgrel=2
pkgdesc="Port of Android 5/6 (Lollipop/Marshmallow)'s material design icons to Arch."
arch=('any')
url="https://github.com/GreenRaccoon23/${pkgname}"
license=('GPL3')
makedepends=('intltool' 'librsvg' 'gtk-update-icon-cache')
provides=("${pkgname}")
-conflicts=("${pkgname}")
+conflicts=("${pkgname}" "${pkgname}-git")
options=('!strip')
install="${pkgname}.install"
# To revert to an older version, use an archive from here:
-# https://github.com/GreenRaccoon23/archdroid-icon-theme/raw/master/bak
-source=("https://github.com/GreenRaccoon23/${pkgname}/raw/master/${pkgname}.tar.xz")
+# https://raw.githubusercontent.com/GreenRaccoon23/archdroid-icon-theme/raw/master/bak
+source=("https://raw.githubusercontent.com/GreenRaccoon23/${pkgname}/master/${pkgname}.tar.xz")
+# If you see an error like this:
+# ==> ERROR: One or more files did not pass the validity check!
+# then comment out or delete the line below.
md5sums=("db3cd391f7f1d7ed767b6cff4a85475c")
prepare() {
@@ -43,18 +46,17 @@ prepare() {
return;
fi;
- error "Required font 'Roboto' is not installed."
- error "Please install a font package which includes 'Roboto', such as:"
+ error "Required font 'Roboto' is not installed.";
+ error "Please install a font package which includes 'Roboto', such as:";
for e in ttf-roboto ttf-roboto-font ttf-google-fonts-git ttf-google-fonts-hg otf-google-fonts-hg; do
echo "${e}";
done;
return 1;
-}
+};
package() {
msg2 "Installing ${pkgname}...";
cd ${pkgname};
install -dm 755 "${pkgdir}"/usr/share/icons;
cp -drf --no-preserve='ownership' . "${pkgdir}"/usr/share/icons/;
-}
-
+};