summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreenRaccoon232015-07-18 09:27:43 -0400
committerGreenRaccoon232015-07-18 09:27:43 -0400
commitdcbe4a34bbc8bf7145b0a165e0c779b747b6453d (patch)
treea54c7a6d291adea7d261067991b470189929229f
parent22336e9c6214969755db3c2031b66b84b5b30fc2 (diff)
downloadaur-dcbe4a34bbc8bf7145b0a165e0c779b747b6453d.tar.gz
added a couple more icons
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD36
-rwxr-xr-xarchdroid-icon-theme.install79
3 files changed, 62 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01548324f8ca..3f5ccb624614 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = archdroid-icon-theme
pkgdesc = Port of Android 5.0 Lollipop's material design icons to Arch.
- pkgver = r79.4ea3b0a
+ pkgver = r86.ab8e2ae
pkgrel = 1
url = https://github.com/GreenRaccoon23/archdroid-icon-theme
install = archdroid-icon-theme.install
@@ -12,7 +12,7 @@ pkgbase = archdroid-icon-theme
provides = archdroid-icon-theme
conflicts = archdroid-icon-theme
source = https://github.com/GreenRaccoon23/archdroid-icon-theme/raw/master/archdroid-icon-theme.tar.xz
- md5sums = 9a5cddd7b567c484e6e8f9c8f40ee5e5
+ md5sums = 8ca3630ee86e77799c013e9d10314360
pkgname = archdroid-icon-theme
diff --git a/PKGBUILD b/PKGBUILD
index b689c9d25151..0a6e6717d1e7 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: GreenRaccoon23 <GreenRaccoon a t gmail d o t com>
pkgname=archdroid-icon-theme
-pkgver=r79.4ea3b0a
+pkgver=r86.ab8e2ae
pkgrel=1
pkgdesc="Port of Android 5.0 Lollipop's material design icons to Arch."
arch=('any')
@@ -13,27 +13,27 @@ conflicts=("${pkgname}")
#options=('!strip')
install="${pkgname}.install"
source=("https://github.com/GreenRaccoon23/${pkgname}/raw/master/${pkgname}.tar.xz")
-md5sums=("9a5cddd7b567c484e6e8f9c8f40ee5e5")
-
-_error2() {
- for e; do
- echo " ${e}";
- done;
-}
+# To revert to an older version, find them here:
+# https://github.com/GreenRaccoon23/archdroid-icon-theme/raw/master/bak
+md5sums=("8ca3630ee86e77799c013e9d10314360")
prepare() {
- if ! fc-list | grep Roboto >/dev/null; then
- error "Required font 'Roboto' is not installed."
- error "Please install a font package which includes 'Roboto', such as:"
- _error2 ttf-roboto ttf-roboto-font ttf-google-fonts-git ttf-google-fonts-hg otf-google-fonts-hg;
- return 1;
- fi;
+ if fc-list | grep Roboto >/dev/null; then
+ return;
+ fi;
+
+ error "Required font 'Roboto' is not installed."
+ error "Please install a font package which includes 'Roboto', such as:"
+ for e in ttf-roboto ttf-roboto-font ttf-google-fonts-git ttf-google-fonts-hg otf-google-fonts-hg; do
+ echo "${e}";
+ done;
+ return 1;
}
package() {
- msg2 "Installing ${pkgname}..." ;
- cd ${pkgname} ;
- install -dm 755 "${pkgdir}"/usr/share/icons
- cp -drf --no-preserve='ownership' . "${pkgdir}"/usr/share/icons/
+ msg2 "Installing ${pkgname}...";
+ cd ${pkgname};
+ install -dm 755 "${pkgdir}"/usr/share/icons;
+ cp -drf --no-preserve='ownership' . "${pkgdir}"/usr/share/icons/;
}
diff --git a/archdroid-icon-theme.install b/archdroid-icon-theme.install
index 0f030dd835a8..31e02bc53c60 100755
--- a/archdroid-icon-theme.install
+++ b/archdroid-icon-theme.install
@@ -1,71 +1,76 @@
+_color() {
+ tput bold && tput setaf "${1}";
+ if ! [ "${2}" ]; then
+ return;
+ fi;
+ printf "%s" "${2}";
+}
+
_green() {
- tput bold && tput setaf 2;
- printf "%s" "${1}";
+ _color "2" "${1}";
}
_blue() {
- tput bold && tput setaf 4;
- printf "%s" "${1}";
+ _color "4" "${1}";
}
_white() {
- tput bold && tput setaf 7;
- for line ; do
- echo "${line}" ;
- done ;
+ _color "7";
+ for line ; do
+ echo "${line}" ;
+ done ;
}
_msg() {
- _green "==> ";
- _white "$@";
- tput sgr 0;
+ _green "==> ";
+ _white "$@";
+ tput sgr 0;
}
_msg2() {
- _blue " -> ";
- _white "$@";
- tput sgr 0;
+ _blue " -> ";
+ _white "$@";
+ tput sgr 0;
}
_gtkUpdate() {
- _msg "Updating icon cache"...;
+ _msg "Updating icon cache"...;
- a="Archdroid";
- colors=( Amber ArchBlue Blue BlueGrey Brown Cyan DeepOrange DeepPurple Green Grey Indigo KellyGreen LightBlue LightGreen Lime Orange Pink Purple Red Shamrock Teal Yellow );
+ a="Archdroid";
+ Colors=(
+ Amber ArchBlue Blue BlueGrey
+ Brown Cyan DeepOrange DeepPurple
+ Green Grey Indigo KellyGreen
+ LightBlue LightGreen Lime Orange
+ Pink Purple Red Shamrock
+ Teal Yellow
+ );
- for c in "${colors[@]}"; do
- t="${a}-${c}";
- d="usr/share/icons/${t}";
+ for c in "${Colors[@]}"; do
+ t="${a}-${c}";
+ d="usr/share/icons/${t}";
- _msg2 "${t}";
- gtk-update-icon-cache -ftq "${d}";
- done ;
+ _msg2 "${t}";
+ gtk-update-icon-cache -ftq "${d}";
+ done;
}
_credits() {
- _msg "Credits to Google, Ubuntu Mono, Mint-X, and Numix for this theme"
+ _msg "Credits to Google, Ubuntu Mono, Mint-X, and Numix for this theme";
}
post_install() {
- _gtkUpdate;
-
- _credits;
-
- go=(
- "To enable icons for golang scripts, manually run this command:"
- 'sudo echo "text/x-go go" | sudo tee -a /etc/mime.types'
- );
- _msg "${go[@]}";
+ _gtkUpdate;
+ _credits;
}
post_upgrade() {
- _gtkUpdate;
-
- _credits;
+ _gtkUpdate;
+ _credits;
}
post_remove() {
- gtk-update-icon-cache;
+ gtk-update-icon-cache;
}
# vim: ts=2 sw=2 et: