summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Lamskoy2015-06-09 12:41:53 +0300
committerEugene Lamskoy2015-06-09 12:41:53 +0300
commit7ec6652d57fd14f048d9a6c40873068262dada0b (patch)
treef178bc7418cb05aa9953b4d82115c5a970f36e70
downloadaur-7ec6652d57fd14f048d9a6c40873068262dada0b.tar.gz
Archey2 initial
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD41
-rw-r--r--python27.patch19
4 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..10939f93ef57
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = archey2
+ pkgdesc = Simple python script that displays the arch logo and some basic information. Python 2.x version
+ pkgver = 20121013
+ pkgrel = 1
+ url = http://github.com/djmelik/archey
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = python2
+ provides = archey
+ conflicts = archey3
+ conflicts = archey
+ source = python27.patch
+ md5sums = d7b47e6e79a9926ce1f8502fb1070426
+
+pkgname = archey2
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e05240c6677d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+src/*
+pkg/*
+*.tar.gz
+*.tar.zx
+*.tar.bz2
+.AURINFO
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45469ca2dae9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Contributor: Melik Ludwig Manukyan <melik@archlinux.us>
+
+pkgname=archey2
+pkgver=20121013
+pkgrel=1
+pkgdesc="Simple python script that displays the arch logo and some basic information. Python 2.x version"
+
+arch=('i686' 'x86_64')
+url="http://github.com/djmelik/archey"
+license=('GPL')
+depends=('python2')
+makedepends=('git')
+provides=('archey')
+conflicts=('archey3' 'archey')
+md5sums=('d7b47e6e79a9926ce1f8502fb1070426')
+source=('python27.patch')
+
+_gitroot="git://github.com/djmelik/archey.git"
+_gitname="archey"
+
+build() {
+ cd ${srcdir}
+ rm -rf archey
+ msg "Connecting to GIT server...."
+
+ if [ -d archey ] ; then
+ cd archey && git pull origin
+ msg "The local files are updated."
+ else
+ git clone ${_gitroot}
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting make..."
+
+ cd ${srcdir}/archey
+ patch -p1 -i ${srcdir}/python27.patch
+
+ install -D -m755 archey ${pkgdir}/usr/bin/archey || return 1
+ install -D -m644 COPYING ${pkgdir}/usr/share/licenses/archey/COPYING
+}
diff --git a/python27.patch b/python27.patch
new file mode 100644
index 000000000000..22464649ab15
--- /dev/null
+++ b/python27.patch
@@ -0,0 +1,19 @@
+--- bin/archey 2012-10-13 01:04:18.000000000 +0300
++++ bin/archey 2012-10-13 01:10:07.008684591 +0300
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #
+ # Archey [version 0.3.0]
+ #
+@@ -91,8 +91,8 @@
+ \x1b[0m'''
+ }
+
+-processes = str(subprocess.check_output(('ps', '-u', getuser(), '-o', 'comm',
+- '--no-headers')), encoding='utf8').rstrip('\n').split('\n')
++processes = str(subprocess.check_output(('ps', '-u', getuser(), '-o', 'comm',
++ '--no-headers'))).rstrip('\n').split('\n')
+
+ #---------------Classes---------------#
+