summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorakepinski2018-04-02 21:30:31 +0200
committerakepinski2018-04-02 21:30:31 +0200
commit0e862e02856894310547cf0241f62fe04ee1b60f (patch)
tree3368c149f60c3eb609ec8e9553e5946d452a1641
parentd130daf83e0afdfcaefadea91ef05c282c98b693 (diff)
downloadaur-0e862e02856894310547cf0241f62fe04ee1b60f.tar.gz
1.0.5 pre7
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD19
2 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c594693d666a..a8138d157d8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = archfetch
pkgdesc = Neofetch, but simplified. For Arch Linux.
pkgver = 1.0.4
- pkgrel = 6
+ pkgrel = 7
url = https://github.com/xxczaki/archfetch/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 5869465fa289..0fb6eaff25f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Antoni Kepinski <hello[at]akepinski[dot]me>
pkgname=archfetch
pkgver=1.0.4
-pkgrel=6
+pkgrel=7
pkgdesc="Neofetch, but simplified. For Arch Linux."
url="https://github.com/xxczaki/archfetch/"
arch=('i686' 'x86_64')
@@ -10,12 +10,17 @@ makedepens=('git')
_gitroot="git://github.com/xxczaki/archfetch.git"
_gitname="archfetch"
-package() {
- cd "$srcdir"
- if [ -r $_gitname ] ; then
- cd $_gitname && git pull origin
+package() {
+ cd "${PKGMK_SOURCE_DIR}"
+
+ if cd "${pkgname}"; then
+ git fetch -q
+ git reset --hard origin/master
else
- git clone $_gitroot $_gitname
- fi
+ git clone ${_gitroot} ${_gitname}
+ cd "${pkgname}"
+ fi
+
sudo install -Dm755 archfetch "${PKG}/usr/bin/archfetch"
}
+