summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorakepinski2018-04-02 21:16:23 +0200
committerakepinski2018-04-02 21:16:23 +0200
commit133ddbdc8fb49e07618b1d7f671697480d7f49ac (patch)
tree4540e9e4117f4a991ca1deaa820d268f45fad863
parent44a74984a1da917523ed66683c0134926b05efb5 (diff)
downloadaur-133ddbdc8fb49e07618b1d7f671697480d7f49ac.tar.gz
1.0.5 pre3
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD20
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b42fae1cf234..b52788feb14b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = archfetch
pkgdesc = Neofetch, but simplified. For Arch Linux.
pkgver = 1.0.4
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/xxczaki/archfetch/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 9cd92f062b7d..d78f4494ad46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Antoni Kepinski <hello[at]akepinski[dot]me>
pkgname=archfetch
pkgver=1.0.4
-pkgrel=3
+pkgrel=4
pkgdesc="Neofetch, but simplified. For Arch Linux."
url="https://github.com/xxczaki/archfetch/"
arch=('i686' 'x86_64')
@@ -10,16 +10,14 @@ depends=()
makedepens=('git')
source=("git+git://github.com/xxczaki/archfetch.git")
-package() {
- cd "${PKGMK_SOURCE_DIR}"
-
- if cd "${pkgname}"; then
- git fetch -q
- git reset --hard origin/master
- else
- git clone https://github.com/xxczaki/archfetch "${pkgname}"
- cd "${pkgname}"
- fi
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+package() {
+ cd "${PKGMK_SOURCE_DIR}" && cd "${pkgname}"
+ git fetch -q
+ git reset --hard origin/master
sudo install -Dm755 archfetch "${PKG}/usr/bin/archfetch"
}