summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Tompkins2019-12-08 11:18:07 -0600
committerMark Tompkins2019-12-08 11:18:07 -0600
commit57af2fd6f94728c2f9e0058ed5223b529ba5bf18 (patch)
tree7a8a6ee6f3f4bc66bd51b8b73f9ae66d4279be0b
downloadaur-57af2fd6f94728c2f9e0058ed5223b529ba5bf18.tar.gz
Init repo with GIT annotation
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
-rw-r--r--arch-silence-grub-theme-git.install11
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7651e0e7c901
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = arch-silence-grub-theme-git
+ pkgdesc = Arch Silence - GRUB2 theme - GIT version
+ pkgver = r5.9fda3bf
+ pkgrel = 1
+ url = https://github.com/fghibellini/arch-silence
+ install = arch-silence-grub-theme-git.install
+ arch = any
+ license = GPL
+ makedepends = git
+ conflicts = arch-silence-grub-theme
+ source = git+https://github.com/fghibellini/arch-silence.git
+ md5sums = SKIP
+
+pkgname = arch-silence-grub-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a1e1bb27ef9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Mark Tompkins
+
+pkgname=arch-silence-grub-theme-git
+_gitname="arch-silence"
+pkgver=r5.9fda3bf
+pkgrel=1
+pkgdesc="Arch Silence - GRUB2 theme - GIT version"
+arch=('any')
+license=('GPL')
+depends=()
+optdepends=()
+install="${pkgname}.install"
+url="https://github.com/fghibellini/arch-silence"
+source=('git+https://github.com/fghibellini/arch-silence.git')
+makedepends=('git')
+md5sums=('SKIP')
+conflicts=("arch-silence-grub-theme")
+
+pkgver() {
+ cd ${srcdir}/${_gitname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ mkdir -p "${pkgdir}/boot/grub/themes/${_gitname}"
+ cp -TR "${srcdir}/${_gitname}/theme" "${pkgdir}/boot/grub/themes/${_gitname}"
+}
diff --git a/arch-silence-grub-theme-git.install b/arch-silence-grub-theme-git.install
new file mode 100644
index 000000000000..95dc9e86a140
--- /dev/null
+++ b/arch-silence-grub-theme-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo '==> To select the arch-silence theme you must:'
+ echo '==> 1. Open the file "/etc/default/grub" and inside it update the variable GRUB_THEME="/boot/grub/themes/arch-silence/theme.txt"'
+ echo '==> 2. Update the grub config by running "sudo grub-mkconfig -o /boot/grub/grub.cfg"'
+}
+
+# should run in the pre phase and check that a different theme was chosen
+# if this is not the case then the removal should be denied
+post_remove() {
+ echo '==> Make sure you selected a different theme and updated your grub config.'
+}