summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-13 02:47:57 +0300
committerDimitris Kiziridis2020-07-13 02:47:57 +0300
commit9d6dc05882b6a55510807b32f02562b944685893 (patch)
tree67a1de0f5639e8c4d9ce80b8348566b3f2efbe4f
downloadaur-9d6dc05882b6a55510807b32f02562b944685893.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad3889311333
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = archifiltre-bin
+ pkgdesc = Provides you with an export script that you can run directly on your file server. It allows you to generate a file that can be directly sent to an archivist
+ pkgver = 2.1.1
+ pkgrel = 1
+ url = https://archifiltre.fabrique.social.gouv.fr
+ arch = x86_64
+ license = MIT
+ makedepends = gendesk
+ depends = zlib
+ provides = archifiltre
+ options = !strip
+ source = archifiltre-2.1.1.tar.gz::https://github.com/SocialGouv/archifiltre/releases/download/v2.1.1/archifiltre.tar.gz
+ source = LICENSE::https://github.com/SocialGouv/archifiltre/raw/master/LICENSE
+ sha256sums = 689cfd97dd09906f70d140cc6816d9b08c0ab3773eb2096fae494469eb21a97d
+ sha256sums = 65391aaa97d61e1d969cdbd8d822ef708c9e9b3a9b6845f18ed52047496187d3
+
+pkgname = archifiltre-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70414b26dc55
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=archifiltre-bin
+pkgver=2.1.1
+pkgrel=1
+pkgdesc="Provides you with an export script that you can run directly on your file server. It allows you to generate a file that can be directly sent to an archivist"
+arch=('x86_64')
+url='https://archifiltre.fabrique.social.gouv.fr'
+license=('MIT')
+provides=("${pkgname%-bin}")
+options=('!strip')
+depends=('zlib')
+makedepends=('gendesk')
+source=("${pkgname%-bin}-${pkgver}.tar.gz::https://github.com/SocialGouv/archifiltre/releases/download/v${pkgver}/archifiltre.tar.gz"
+ 'LICENSE::https://github.com/SocialGouv/archifiltre/raw/master/LICENSE')
+sha256sums=('689cfd97dd09906f70d140cc6816d9b08c0ab3773eb2096fae494469eb21a97d'
+ '65391aaa97d61e1d969cdbd8d822ef708c9e9b3a9b6845f18ed52047496187d3')
+
+package() {
+ chmod 755 ./${pkgname%-bin}-${pkgver}.AppImage
+ ./${pkgname%-bin}-${pkgver}.AppImage --appimage-extract
+ install -Dm644 squashfs-root/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png "${pkgdir}/usr/share/pixmaps/ananas-desktop.png"
+ gendesk -f -n --pkgname "${pkgname%-bin}" \
+ --pkgdesc "$pkgdesc" \
+ --name "Archifiltre" \
+ --comment "$pkgdesc" \
+ --exec "${pkgname}" \
+ --categories 'Utility;Application;' \
+ --icon "${pkgname%-bin}"
+ install -Dm644 "${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -d "${pkgdir}/usr/bin"
+ install -Dm755 "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" "${pkgdir}/usr/share/${pkgname%-bin}/${pkgname}.AppImage"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -s /usr/share/${pkgname%-bin}/${pkgname}.AppImage "${pkgdir}/usr/bin/${pkgname%-bin}"
+} \ No newline at end of file