summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreolianoe2015-07-10 11:39:50 +0200
committereolianoe2015-07-10 11:39:50 +0200
commit462dde207989aa638addbb1e19baaf3326094a66 (patch)
tree0f743b0c7ad95f8f2746ea00e09f3e3bc9a30eb7
parenta45a15f3916e491c3ad2ce20890e2d23c54d2f63 (diff)
downloadaur-462dde207989aa638addbb1e19baaf3326094a66.tar.gz
Correct dependencies
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6911e088b49..e51aceefd5cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,22 @@
pkgbase = archimedes-tools
pkgdesc = Archimedes is a set of tools, including mesh generators, for performing unstructured finite element simulations
pkgver = 1.6
- pkgrel = 5
+ pkgrel = 6
url = http://www.cs.cmu.edu/~quake/archimedes.html
arch = i686
arch = x86_64
license = custom
- depends = libx11
+ makedepends = libx11
source = http://www.netlib.org/voronoi/triangle.zip
md5sums = 10aff8d7950f5e0e2fb6dd2e340be2c9
pkgname = triangle
pkgdesc = A Two-Dimensional Quality Mesh Generator and Delaunay Triangulator.
url = http://www.cs.cmu.edu/~quake/triangle.html
+ depends = glibc
pkgname = showme
pkgdesc = Show Me graphically displays the contents of geometric files, especially those generated by Triangle
url = http://www.cs.cmu.edu/~quake/showme.html
+ depends = libx11
diff --git a/PKGBUILD b/PKGBUILD
index 895bf5400d23..47de1c88ddce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,14 @@
pkgbase=('archimedes-tools')
pkgname=('triangle' 'showme')
pkgver=1.6
-pkgrel=5
+pkgrel=6
arch=('i686' 'x86_64')
url='http://www.cs.cmu.edu/~quake/archimedes.html'
pkgdesc='Archimedes is a set of tools, including mesh generators, for performing unstructured finite element simulations'
license=('custom')
source=('http://www.netlib.org/voronoi/triangle.zip')
md5sums=('10aff8d7950f5e0e2fb6dd2e340be2c9')
-depends=('libx11')
+makedepends=('libx11')
build(){
gcc ${CFLAGS} -o triangle triangle.c -lm
@@ -25,6 +25,7 @@ build(){
package_triangle() {
url='http://www.cs.cmu.edu/~quake/triangle.html'
pkgdesc='A Two-Dimensional Quality Mesh Generator and Delaunay Triangulator.'
+ depends=('glibc')
install -Dm755 triangle "${pkgdir}/usr/bin/triangle"
install -Dm644 triangle.h "${pkgdir}/usr/include/triangle.h"
@@ -35,6 +36,7 @@ package_triangle() {
package_showme() {
url='http://www.cs.cmu.edu/~quake/showme.html'
pkgdesc='Show Me graphically displays the contents of geometric files, especially those generated by Triangle'
+ depends=('libx11')
install -Dm755 showme "${pkgdir}/usr/bin/showme"
install -Dm644 "${srcdir}/README" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"