summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Hvornum2023-07-31 09:45:00 +0200
committerAnton Hvornum2023-07-31 09:45:00 +0200
commitde44a569c82520a58b0ecf9f516a55136549d8df (patch)
tree5d0ca69d481090297070fd9fe341e8b771d8cbb3
parentc6ec337e3ad5d4eba581d2a8e3a72395738654c3 (diff)
downloadaur-de44a569c82520a58b0ecf9f516a55136549d8df.tar.gz
Updated the build to include all dependencies and bump to move to v2.6.0 build steps
-rw-r--r--PKGBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 56c0b78a9aa4..a8ae12b6e471 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,28 @@
_name=archinstall
pkgname=archinstall-git
-pkgver=2.5.4.r8.g315f87c
+pkgver=2.6.0.r5.g0852a7c
pkgrel=1
pkgdesc="Just another guided/automated Arch Linux installer with a twist"
arch=('any')
url="https://github.com/archlinux/$_name"
license=('GPL3')
depends=(
+ 'arch-install-scripts'
+ 'btrfs-progs'
+ 'coreutils'
+ 'cryptsetup'
+ 'e2fsprogs'
+ 'kbd'
+ 'pciutils'
+ 'procps-ng'
'python'
+ 'python-pyparted'
+ 'python-simple-term-menu'
'systemd'
+ 'util-linux'
)
makedepends=(
- 'git'
'python-setuptools'
'python-sphinx'
'python-build'
@@ -37,12 +47,7 @@ pkgver() {
}
prepare() {
- cd $_name
-
- # Remove symlinks from the package source
- # and move the actual files in before packaging.
- rm -fv $_name/{examples,profiles}
- mv -v examples profiles $_name/
+ cd $pkgname-$pkgver
}
build() {