summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2019-12-06 10:27:20 -0500
committerSolomon Choina2019-12-06 10:27:20 -0500
commitce2b499d38167e4d4c433b3c68c02aec1ce7c775 (patch)
tree654fd45415a56678c6cd9bf6330ed4301fc637e8
parent57197fb3dd7af68e55affc3713c0ea190f3d92f6 (diff)
downloadaur-ce2b499d38167e4d4c433b3c68c02aec1ce7c775.tar.gz
updpkgver
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96121d177f9b..d2872f0e22ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = archipelago
pkgdesc = An open-source terminal emulator built on web technology
- pkgver = 3.2.0
+ pkgver = 3.8.1
pkgrel = 1
epoch = 1
url = https://github.com/npezza93/archipelago
@@ -8,16 +8,17 @@ pkgbase = archipelago
license = MIT
makedepends = git
makedepends = yarn
- makedepends = node-gyp
makedepends = python2
+ makedepends = libpng
makedepends = libx11
- makedepends = rpm-org
+ makedepends = node-gyp
+ makedepends = libxtst
depends = nodejs
depends = libxkbfile
depends = libx11
conflicts = archipelago-bin
- source = https://github.com/npezza93/archipelago/archive/v3.2.0.tar.gz
- sha512sums = 6a4fbf877b18e00ae057a333165533c1168d009be2c00be8eccb764304b4320734a0d01a6d1511c6dc77e9e745595f9ec16e3a9a980622c75a282ff06807e50f
+ source = https://github.com/npezza93/archipelago/archive/v3.8.1.tar.gz
+ sha512sums = aaa926a4b149c5289437b7d01d1ac969d47a55eb1727923db6a3d7ac693170bf005773dac81d2aabafef4e3a813568d762a01ed6cb213d524949469a035d7139
pkgname = archipelago
diff --git a/PKGBUILD b/PKGBUILD
index 4786a3fc9288..671911f81468 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Solomon Choina <shlomochoina@gmail.com>
pkgname=archipelago
-pkgver=3.2.0
+pkgver=3.8.1
epoch=1
pkgrel=1
pkgdesc="An open-source terminal emulator built on web technology"
@@ -10,15 +10,17 @@ url="https://github.com/npezza93/archipelago"
license=("MIT")
conflicts=('archipelago-bin')
depends=('nodejs' 'libxkbfile' 'libx11')
-makedepends=("git" "yarn" 'node-gyp' 'python2' 'libx11' 'rpm-org')
+makedepends=("git" "yarn" 'python2' 'libpng'
+ 'libx11' 'node-gyp' 'libxtst')
source=("https://github.com/npezza93/archipelago/archive/v$pkgver.tar.gz")
-sha512sums=('6a4fbf877b18e00ae057a333165533c1168d009be2c00be8eccb764304b4320734a0d01a6d1511c6dc77e9e745595f9ec16e3a9a980622c75a282ff06807e50f')
+sha512sums=('aaa926a4b149c5289437b7d01d1ac969d47a55eb1727923db6a3d7ac693170bf005773dac81d2aabafef4e3a813568d762a01ed6cb213d524949469a035d7139')
build() {
cd $srcdir/$pkgname-$pkgver
yarn install --ignore-engines
yarn run compile
- yarn run build
+ yarn run pack
+ ./node_modules/.bin/electron-builder --linux deb
}
package() {