summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormauriciodelima212023-09-03 00:32:22 -0300
committermauriciodelima212023-09-03 00:32:22 -0300
commit1d7028c7e273419dc8ed9889c0ad2949b7d5002e (patch)
treede0da9bd20338118c4905e71350394c52d76ecdf
parentaadee6d43d15fc99c2848a7ad2d0f78eb5541569 (diff)
downloadaur-1d7028c7e273419dc8ed9889c0ad2949b7d5002e.tar.gz
Commit inicial
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
-rw-r--r--calamares-config.install30
3 files changed, 34 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..18b91a26897b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = archiso-calamares-config
+ pkgdesc = Calamares for Archiso
+ pkgver = 72
+ pkgrel = 1
+ url = https://gitlab.com/uaiso/labs/uarchiso
+ arch = any
+ license = GPL3
+ makedepends = git
+ provides = archiso-calamares-config
+ options = !strip
+ options = !emptydirs
+ source = archiso-calamares-config::git+https://gitlab.com/uaiso/labs/uarchiso/archiso-calamares-config
+ sha256sums = SKIP
+
+pkgname = archiso-calamares-config
diff --git a/PKGBUILD b/PKGBUILD
index d38d0dca9f50..dde04997a3df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,35 @@
# Maintainer: Mauricio de Lima <emauricio@uai21.com>
-pkgname=calamares-config
-_destname1="/etc"
-pkgver=71
+pkgname=archiso-calamares-config
+pkgver=72
pkgrel=1
pkgdesc="Calamares for Archiso"
arch=('any')
-url="https://github.com/UaiSO21"
+url="https://gitlab.com/uaiso/labs/uarchiso"
license=('GPL3')
makedepends=('git')
-#depends=('')
provides=("${pkgname}")
options=(!strip !emptydirs)
source=(${pkgname}::"git+${url}/${pkgname}")
sha256sums=('SKIP')
+
if [ -e "${pkgname}.install" ];then
install=${pkgname}.install
fi
+
package() {
- install -dm755 ${pkgdir}${_destname1}
- cp -r ${srcdir}/${pkgname}${_destname1}/* ${pkgdir}${_destname1}
-}
+ InternalDir="${srcdir}/${pkgname}"
+ # Copy files
+ if [ -d "${InternalDir}/usr" ]; then
+ cp -r "${InternalDir}/usr" "${pkgdir}/"
+ fi
+
+ if [ -d "${InternalDir}/etc" ]; then
+ cp -r "${InternalDir}/etc" "${pkgdir}/"
+ fi
+
+ if [ -d "${InternalDir}/opt" ]; then
+ cp -r "${InternalDir}/opt" "${pkgdir}/"
+ fi
+}
diff --git a/calamares-config.install b/calamares-config.install
deleted file mode 100644
index 747a227a1439..000000000000
--- a/calamares-config.install
+++ /dev/null
@@ -1,30 +0,0 @@
-## arg 1: the new package version
-#pre_install() {
-# locale-gen
-#}
-
-## arg 1: the new package version
-#post_install() {
-#
-#}
-
-## arg 2: the old package version
-#pre_upgrade() {
- # do something here
-#}
-
-## arg 2: the old package version
-#post_upgrade() {
- # do something here
-#}
-
-## arg 1: the old package version
-#pre_remove() {
- # do something here
-#}
-
-## arg 1: the old package version
-post_remove() {
- /usr/bin/sed -i 's/^User=liveuser/User=/' /etc/sddm.conf.d/kde_settings.conf
-}
-